[SOLVED] "minicom ama0" Permission Denied


#1

Hi,

I was following steps in the Ultrasonic tutorial (http://www.dexterindustries.com/Arduberry/example-projects-with-arduberry-and-raspberry-pi/ultrasonic-ranger/). Every step was fine (code uploaded to Raspberry,etc.), until I reach the step4.

When typing into ‘inicom ama0’ in the command line, I received the following error:

minicom: cannot open /dev/ttyAMA0: No such file or directory

My setup is that the Raspberry pi connects to the ArduBerry then to the Arduino basesheild. Meanwhile, the Raspberry pi is also connected to the GopiGo.

I didn’t have this problem yesterday, and I don’t know why I am running into this issue now. Do you know how to solve it?

Thanks,
NK


#2

What happens when, in the command line, you run the full command:

sudo minicom -b 9600 -o -D /dev/ttyAMA0

Are you running the Raspbian for Robots operating system, or another?


#3

Yes, I am running the Raspbian for robots image downloaded from Dexter official site. I will run the command you suggested once I get home today.

Thanks in advance!
Nk


#4

No problem. I wonder if this happened after an update?


#5

I don’t remember exactly. But this was working fine before.


#6

Hi,

I have tried to run the command you suggested above, but there was no response (see attachment). I went into the /dev directory, and I could not find the ttyAMA0.
Do you know what I should do next?

Thanks,
NK


#7

I unplugged everything and re-plugged the arduberry and the base shield. Now I run ‘sudo minicom AMA0’ and it minicom finally opened. However, now I have a new problem that there is no reading in the minicom… I uploaded UltrasonicDisplayOnTerm successfully, however when I open minicom, there is no reading…


#8

I am still stuck here…Minicom now opens but it is on /dev/tty8 port. When I tried to change the port in configuration serial port setup to dev/ttyAMA0, I still get the error ‘minicom: cannot open /dev/ttyAMA0: No such file or directory’.

Can someone please help me?

THX!


#9

I reinstalled the SD card image. Now it works.