[SOLVED] My new GoPiGo3 will not bootup

dexteros
faq
gopigo3

#1

The power led blinks green forever. It never goes to solid green. How do I troubleshoot this problem?
I’m using the SD card with DexterOS.


#2

Hi @adam.morawicz,

The Raspberry Pi has 2 status LEDs (excluding the first Raspberry Pis that had 5 of them):

  • A red LED which signifies the presence of a power supply.

  • A green LED which indicates the activity on the micro SD Card.

So, you’re saying the green LED blinks forever - that’s perfectly okay since it represents the activity on your micro SD Card. The blinking frequency should tone down once the Raspberry Pi boots up.


You’re also saying that your GoPiGo3 doesn’t boot up.
Here are a couple of questions / suggestions that may help us understand what’s going on:

  1. How are you powering up your Raspberry Pi?
    Is it through a battery pack or do you use the microUSB that’s on the Raspberry Pi?
    If the battery pack is low on battery, than the Raspberry Pi might not properly boot up - the micro SD Card can also go bad because of this.

  2. Can you see a WiFi network called GoPiGo after you’ve left your Raspberry Pi boot up long enough (say 3 minutes)?

  3. What Raspberry Pi do you have. If it’s not a Raspberry Pi 3, than you need a WiFi dongle for it and also you need to wait some more time before it completely boots up.

  4. Please connect a USB Key to your Raspberry Pi and boot it up. After leaving your Raspberry Pi “alone” for 5 minutes, can you see a Logs folder onto your USB Key. If so, could you archive the folder and attach it here?


That’s all I can say for now, Adam.

Thank you!


#3

Hi Robert,

The red power LED on my Raspberry Pi 3 is illuminated.
The green micro SD activity LED blinks forever, it never stops blinking. According to the online connection instructions the green LED should stop blinking.
The WiFi dongle is installed, but the WiFi LED never illuminates and I don’t see the network GoPiGo3 detected by my HP Chromebook.

I will next attempt to connect my Raspberry Pi 3 to a monitor through HDMI per your suggestion.
Also, I will check for are any log files on my USB drive.
I will also provide a video of my robot.

Adam M


#4

Hi Robert,

After 10 minutes, there are no files logged on my USB drive and there is no HDMI signal.

Adam Morawicz


#5

Here are some images of my GoPiGo3.

Adam M


#6

2nd image


#7

4th image


#8

6th image


#9

Hi @adam.morawicz,

So we have the following situation at the moment:

  1. The green LED keeps on flashing and it never tones down.

  2. No log files found on the USB Key after 10 minutes.

  3. You’re using a Raspberry Pi 3.

  4. You’re using the micro SD Card you’ve received from us - called DexterOS.

  5. No output on the HDMI port - plugged in before powering up the Raspberry Pi.


Can you confirm us that before plugging the HDMI into the Raspberry Pi, you had the Raspberry Pi turned off?

Plugging the HDMI into the Raspberry Pi while it’s turned on, won’t get you any output - the HDMI is checked on boot and if it isn’t found, the HDMI port is turned off - that’s the reason.


Also, is there any possibility for you to have another micro SD Card laying around?

We might do 2 things after all of the above are confirmed:

  1. Burn a new DexterOS on your (received) micro SD Card.

  2. If the point 1 fails, then burn a new DexterOS on another micro SD Card.


Thank you!


#10

Yes, your five point summary of the problem is correct.

If the SD micro card was blank, would this cause the same symptoms? I also received the SD micro card for Raspbian, perhaps I should try that one instead?

Adam M


#11

I tried my Raspbian micro SD card and it appears to work.

I have downloaded DexterOS v1.0.1 and will attempt to etch a new SD card.

Adam M


#12

Hi Robert,

I got it working now with DexterOS. I purchased an SD card reader/writer and 16GB San Disk to complete the task. I downloaded DexterOS from a link I found in the forum and wrote the image onto my new SD card using Windows Disk Imager.
I am now successfully connected via WiFi to DextorOS home page.

Adam M


#13

Hi @adam.morawicz,

It’s really great to hear it worked for you.
It’s not great that it didn’t work from the beginning though.


I’m curious as to why our DexterOS micro SD Card didn’t work.

If you haven’t reformatted our micro SD Card (with DexterOS on it), could you plug it in your computer and check if there’s a partition with a bunch of files in it?

Or if you’re up to it, could you make an image of that micro SD Card (the one that didn’t work) with Win32DiskImager and put it on a Drive or Dropbox and share the link with us?
We’d like to test it and see what was the issue.


Thank you!


#14

For those wandering in: this is a helpful video for making sure the SD Card is working properly.


#15

This topic was automatically closed after 25 hours. New replies are no longer allowed.