[SOLVED] No wifi with Raspbian for Robots

I’ve downloaded the latest version of Raspbian for Robots (2018-06-27) and I’ve tried everything to use the wifi connection but without any succes.
I see a list of all possible networks but when I select the proper one and enter the password nothing happens. Very frustrating. Any suggestions?

That’s close to being impossible. Unless there’s something going wrong with the AP (the router’s WiFi), then you should be able to connect to any WiFi with your Raspberry Pi.

Maybe the folks on the Raspberry Pi forum can give you a better explanation. Raspbian For Robots is only an overlay of our libraries on top of Raspbian and that’s it.

Thank you!

Hello @guuskoning

Can you define what you mean by “nothing happens”?

Could you describe your current setup to make it easier for us to help? Is your Pi physically connected to a router, or do you have a screen&keyboard connected to it? How do you access it?

I’m assuming you have a Pi3B, but it could be a Pi3B+. Could you confirm which one you have as they have a different wifi .

I’ll do my best to help out.

I’ve ordered a new modem, maybe that will help.

I have an Raspberry Pi 3 and it recognizes the wifi networks. Only when I select one nothing happens.

I’ve also tried it with a older Jessie OS, same problem there.

Are you sure you don’t have any custom setup on your wifi Access Point (router)? Some can be setup with a whitelist of MAC addresses (only allow listed addresses to connect). Are you able to connect to your wifi with other devices (laptop, phone, tablet, etc…)? Before you replace your router, you might try doing a factory reset on it (also might be worthwhile to see if there are any firmware updates available for the router).


Last time I heard of this issue, it was the Pi3 itself which was defective. The wifi chip seemed to have physical damage on it.

I would try connecting to another access point. Maybe set your phone as one, and try to connect to that? If that also fails, I would suspect a defective Pi at this point.


Seems it was a problem with the modem. I’ve installed a new one and everything works fine.

1 Like

Good to hear! Thanks for letting us know.


This topic was automatically closed after 3 days. New replies are no longer allowed.