[SOLVED] Pi automatic shutdown after configuring Arduberry

faq
arduberry

#1

I’ve setup the Arduberry on a model B. I first tried installing the Dexter software on stock Jessie but Sketch didn’t see any Programmers. Checking forums, suggested using Raspbian for Robots so have installed, updated patches. The sketch programmers showed up so I configured via instructions. Compiled and uploaded sample blink code. This appeared successful but shortly afterward sketch froze. Rebooted the pi but from that point, during boot, I see the dexter text screen and last message is requesting hostname change., then screen goes blank like starting in X. After a few seconds, messages appear, indicating the Pi is shutting down. Same behavior with GUI or CLI.

I’ve removed the Arduberry, and Raspbian boots normally. I’ve tried the same card and Arduberry on another model B, same behavior. I also noticed before the Programmer crash with stock Raspbian and Arduberry installer and Raspbian for robots that the Model B is very sluggish with the Arduberry installed. Top showed no obvious process. Board is mounted per:
https://www.dexterindustries.com/Arduberry/getting-started/raspberry-pi-b-arduberry/

Please assist to troubleshoot further.


#2

Hi @warichter1,


I’ve experienced this issue myself once.
Needless to say, I’ve wasted hours until I found what the problem was.

My problem was that I still had the protective covering on the header pins of the Arduberry and because of that, it was (somehow) creating a resistive contact between the pins. So because of that, my Raspberry Pi was continuously booting up and shutting down - just like on a ferris wheel.


Can you confirm us that you’ve plugged the Arduberry all the way down into the Raspberry Pi. An improper contact may lead to such situations.
Maybe sharing with us a photo of your setup will help us diagnose the problem faster - I suggest taking close-up photos.


Thank you!


#3

The foam does appear to be the problem. The Pi now boots and I can upload Blink without issue.

Had left the foam on to protect the pins from being bent. Have never run into this before.

Thanks
Bill


#4

Hi @warichter1,

I’m glad it worked out.
I’m closing the thread now.

Thank you!


#5

Raspberry Pi gpio missing in Arduino ide Programmer list