[SOLVED] Raspberry Pi 3 won't boot with GrovePi+ attached but does boot without GrovePi+ attached

Hello Grove enthusiasts,

I just started using the GrovePi+ and have the strange phenomenon that my Raspberry Pi will only boot if no GrovePi+ is attached yet. If I then mount it onto the Raspi after booting it will immediately be recognized but if it is mounted before booting the Raspi then it won’t come up and be reachable via SSH or even a ping.

some technical facts:
Raspberry Pi 3 Model B
Raspbian image: Stretch (all packages up-to-date)
SD card: Samsung Evo Plus 32GB

Does anyone have a clue?

Thank you and regards,

Hi @pepe,

Is there a black foam stacked on top of your GrovePi? If that’s the case, then the foam acts as a short-circuiter which prevents the RaspberryPi from completely booting up.

Also, we’re still using the Jessie image - we haven’t moved on to Stretch yet because Jessie is still more stable than it.

Thank you!

Do you have any resolution on this?
I have the same exact problem, booting, or shutting down with grovePi+ HAT attached hangs up. But if I were to put the hat after boot, it looks fine as I was able to flash/update firmware successfully.
I have to use stretch for some other libraries.

Hi @kbzn99,

I think that’s a different story. Are you referring to the GrovePi + Pi combo or the HAT (PiSense hat) + GrovePi + Pi trio?

If you’re trying to use a PiSense hat, then it’s not going to work. We had some tests a while back and it didn’t work.

But if you’re just getting this problem with just the GrovePi attached to your Raspberry Pi, then it might be a short circuit between some pins on the GrovePi, or at least there might be a small flow of electrons going from one pin to another of the GrovePi (and therefore between Pi’s pins) that’s big enough to trigger a reset of the Pi.
In this case, it might be useful to hook up the GrovePi to your Raspberry Pi with jumpers incrementally (like 1 by 1) and see if you something similar.


Hi Robert

I am having the issue with raspberry pi and groove Pi+ shield. Whenever I
attach it during the boot, after 4 raspberry screen system tries to correct
for one error. I dont think there is leakage or short, if there were I
think pi would go crazy instead of trying to boot. Also would not short
effect operation after boot, (i.e. not being able to update FW on atmel on

Everything seems to work fine when I attach the HAT after boot.

Btw I tried two Pi3s (one with latest stretch and another with latest
jessie) and two grovePi+ HATs, and both show the same issue. There is
something coming from the GrovePI+ hat that is messing up the boot sequence.


Another update:

If I boot Pi, and attach the HAT while the Pi is powered on, I see I2C and SPI. I can toggle pins, I2C comms even FW update. If at this point I do reboot, there is no boot issue. (Note in this case the HAT is actually never powered off).

If instead, I power off fully, or shutdown Pi, and restart than it hangs up during boot, after 4 raspberry screen.

Just 2 Days ago I flashed the newest Raspbian Stretch and tried again. Now it booted even with the GrovePi Shield attached right from the beginning.
But I have no clue what could have been the issue before :face_with_monocle:

Hi @kbzn99,

I’m thinking where this can come from.
We’re going to pay attention from now on to how our GrovePis behave when using it.

By the way, is this issue you’re describing repeatable? Is it consistent or does it happen from time to time?

Thank you!

Hi, I just saw this post after creating a new one. I have the same issue on Raspberry Jessie where the pi is not booting only with grove plugged in. However, I don’t intend to upgrade to Stretch. Is there a specific kernel version or config that could be causing this problem?

Hi @workspace0017,

When we did tests on the kernel a couple of months ago, the GrovePi worked fine with all versions of the kernel, but all these reports make me think another round of tests should be done.

Just out of curiosity, does it start booting up if you change the version of the kernel to 4.4.50-v7+?
Here’s a thread were we did this:

Thank you!

Hi Robert,
Thanks for the prompt support.
This version of the kernel did work.

Hi @workspace0017,

HA! It shouldn’t have made a difference. This means we need to check the firmware and then possibly come up with a fix for it.

Thank you for reporting it back to us!


unfortunately the phenomenon still exists. I don’t know why the issue wasn’t happening when I played around in December.
It still persists that I can neither boot nor reboot with Grove Pi attached. But when attaching it after booting the Pi, it works (i2cdetect recognizes the Grove Pi with sensors).
Just now I updated all packages of Stretch but no difference.
greetings, pepe

Hi @pepe,

As soon as I’m done with whatever I have on my plate, I’ll hop onto this issue and try to solve it.

But yeah, I also remember having this work before December on much newer versions of the kernel and yet, they now don’t work the same way. I must say it’s strange.

On this PR there’s a screenshot of the tests I ran on the line follower and the GrovePi with different versions of the kernel:

Thank you!

no worries. thanks for caring. I’ll try to supply more details as soon as i discover them. greetings

I have exactly the same issue and it is quite frustrating. I need the grove to be attached at start as I put everything in a housing without a monitor. I tried many hints from the net regarding this (GrovePi+ FW up and down grades, Jessie up and downgrades, a new 3A A/C converter, other SD-Cards…) But at startup my Pi3B with Raspbian hangs (with 4 little raspberries when a monitor is attached).

Is there any Idea before I need to move to other IO-boards?
Thanks a lot for your help!