[SOLVED] Scratch For Robots not working


#1

Hello,
I had your flag waving program working well in Scratch For Robots with my new PivotPi and Rpi3+. I had to reload NOOBS after a hardware problem.

I followed the PivotPi install instructions like I did the first time and loaded

cd /home/pi sudo curl https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/fetch_pivotpi.sh | bash

It puts the Icons on the desktop but they will not open from the desktop OR the source folder. The lights on the pivotpi are all lit up.

PivotPi does not respond in Python code either.

I tried the instructions to make a new card to use Raspbian for Robots but it loads on the USB and will not open when I turn on the RPi. I have tried this from 3 different mirrors and Google Drive and it wont open.

When I had to redo my RPI SD card and loaded NOOBS I saw it didnt have all the OS that I had with the factory card. I dont think it has Stretch - is that the problem?

I made yet another SD with Raspbian and no luck either. I am so frustrated!

Thanks


#2

@robinquidor
I am sorry you’re having this frustrating experience. It looks to me that PivotPi doesn’t get fully installed.

Could you run
curl -kL dexterindustries.com/update_pivotpi | bash instead?

Please, let me know if this helps,
Cleo


#3

Thank you! I will try ASAP.


#4

Nope. It puts 4 icons on the desktop, Scratch FOr Robots, PivotPi Control Panel, Test and Troubleshoot and Advanced Communication. The only one that opens is Advanced communication.


#5

Can someone please help me?


#6

Please forgive me, @robinquidor
I have found some errors that only show up if you don’t use Raspbian for Robots and I have fixed them all except one.

If you run curl -kL dexterindustries.com/update_pivotpi | bash again, you will get all my fixes.

Then for the one that’s left, click on the Raspberry logo, top left, then Preferences, then Raspberry Pi Configuration
Once you get the configuration window, click on Interfaces and make sure I2C is enabled.

enableI2C

There’s code that should enable it, but somehow it’s failing for me and I’m still investigating that.

Click Ok to save this configuration.

Once those are done, you should be fine to run the PivotPi Control Panel, and Scratch.

Let me know if you get it to work. It works fine for me now on a new Raspbian.
Cleo


#7

YES!!! This has worked!! THANK YOU SOOOO MUCH!!


#8

@robinquidor
thanks for letting me know it worked! Apologies again for taking so long .

Enjoy your pivotpi!

Cleo


#9

This topic was automatically closed after 2 days. New replies are no longer allowed.