[SOLVED] SD card Dexter OS Zip Failure

dexteros

#1

Hello,

I’m on my second SD card today and I’ve yet to figure out what is going on. Basically I follow the following steps:

(1) Download Dexteros2.3.0.zip
(2) Unzip using 7zip (also used WinZip)
(3) Use Etcher to flash onto SD card
(4) Flash gets to around 70% and the “device fails”

After the device fails it is no longer detected by my computer. I can re-assign it a new volume “letter” (e.g. default is F), but if I repeat the steps above the device fails.

Any thoughts? I ordered the SD card from Dexter just in case I can’t figure it out by Monday but it shouldn’t be this difficult, right?

Any help is appreciated.


#2

Oh, and possibly related. If I click the disk image file on my desktop it states “disk image is corrupted”.


#3

Can you try and use Etcher with the zipped file directly? No need to unzip. I’ve seen Etcher have issues before when the file was unzipped.
Not saying it’s the case here, just trying to cover all bases.

Cleo


#4

I will try the zipped file directly, definitely haven’t tried that one yet. Thanks for the quick response!


#5

That appears to have worked, or at least the flash was successful. I will report back if I am able to access DexterOS before moving forward! Thanks again!


#6

Okay, so I am currently trying to connect to the piBrick3 and am having no luck so I’m unsure if it actually worked.

(1) Turn on BrickPi3
(2) Ensure PWR is constant (check) and ACT is on and flashing intermittently (check)
(3) Connect Ethernet cord to BrickPi3 to Router
(4) Gopigo shows up on wifi options
(5) Ensure settings are set to automatically find IP address
(6) Attempt to connect to gopigo
(7) Doesn’t take and wifi signal/network disappears from options

I’m not sure how to tell if the SD card set-up was done correctly outside of the ACT/PWR lights. Any help is appreciated. Apologies for all the questions.


#7

Oh no. The BrickPi isn’t supported in DexterOS. That OS is only for the GoPiGo (2, or 3)

For the BrickPi, you have to use Raspbian for Robots. #bearerOfBadNews :frowning:

ETA: https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/


#8

Ah, bummer! Thank you for your time and patience!


#9

Thank you for your time and patience.
We have failed in making it clear that DexterOS is only for GoPiGo.
Mea culpa


#10

Yeah, I agree the instructions could be a bit clearer and the zip/flash issue above is something that could be communicated upfront to save people time in the future. But, alas, robotics is troubleshooting so this process is as much of a part of the learning as anything else!

:slight_smile:


#11

Love your attitude :slight_smile:

I looked over our pages, and on this one , it does say Select the DexterOS zip file in Etcher
I’m open to suggestions as to what would have helped you. What’s needed on our side to make it stand out?

Cleo


#12

For future users, I think the following revision could be made to the following URL:

https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

In the “Using a PC” section:

PC users should download the latest zip compressed file. Files in this directory are arranged and named by date. Select the latest file, and hover your mouse over the file name. Choose the latest file that ends in “.zip”, click on it, and download the file.

After the file is downloaded, we can uncompress it.

Next, un-compress the File. In windows, we use a free program called WinRAR, freeware you can download here. Un-compress the downloaded .zip or .rar file.

Add a section stating “in some instances, flashing the uncompressed file may lead to error. In these cases, flash the zipped format file directly”.

Or something to that effect. Otherwise it’s been smooth sailing since I moved to Raspbian Pi. Thank you for all your help!


#13

@Newton1218
Thank you for your feedback. It seems we forgot one spot about the unzipping. I’ll have that page changed so it doesn’t even mention WinRar and uncompressing. Fewer steps are better for everyone.

Thanks for pointing it out. It’s really helpful!

Cleo


#14

Awesome. Thank you for the feedback! Such a helpful and friendly community!


closed #15

This topic was automatically closed after 5 days. New replies are no longer allowed.