[solved] unable to connect on mac

@All, I had the same issue where the Mac was not able to ping the dex.local, and VNC client cannot connect and all sort of issues. I change to static IP address the raspberry and the issues continued. I had the image on the SD card “Rasbian for robots” 2015.11.09. I decided to reload a new Debian OS to a new SD card (32GB this time), with my own microsd card adapter following this instructions: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

  1. I downloaded the latest OS from here: https://sourceforge.net/projects/dexterindustriesraspbianflavor/à
    from 2016.01.05.
  2. I used Suffit Expander to unzip the zip :slight_smile: getting the .img file
  3. I used this command line to copy the img to the sd card: sudo dd bs=1m if=2015.11.09_Dexter_Industries_wheezy.img of=/dev/rdisk2
    You have to use rdisk if you are using El Capitan OS on the Mac.
    Where 2 is the number of your own card reader (could be 3 or 4), NEVER USE 1
    took 15 minutes to copy the image
  4. moved back the microsd card in the pi, and booted, and now evrerything work property from bonjour dex reconition, ping dex.local, vnc…

@John: you may want to look into your microsd card and microsd card reader quality. It seems that there are a lot of corrupted ones, and the card reader was very bad, like the lock not staying in place, and had bad contacts.


Hey jgailleur, thanks for the update. I assume you started with an 8GB card from us, correct? That’s disapointing to hear that the problem was straight up solved by the SD card quality. I am really glad to hear that you found a way around it, I’ll have to research a little on our SD Card provider, more than a few folks have had problems with the image as its delivered. Thanks for letting me know.

Yes, that is correct it was the 8GB micro sd card with label “Raspbian for robots” 2015.11.09