[solved] unable to connect on mac


#1

Hi,

I have been unable to connect my daughters gopigo robot kit with monthly missions from Kickstarter.

We have two imacs and two macbook air computers in our house.

Here is the current state:

I’m having the same problem.

  1. I am using the sd card you sent with a date of 2015.11.09
  2. Mac to connect
  3. Power light on steady, ACT light blinks for a while then off
  4. Using the AA battery pack
  5. I’m not sure what version of Raspberry Pi that is being used. How can I check?

I have tried to connect using a web browser as well. No luck with that.

Thanks for your help.

Brian


#2

I was able to connect with putty on my MBP with a cat5 connected between the Pi and my MBP.

Also you can plug the Pi into your HDTV with an HDMI cable and then plug a USB keyboard into your Pi and you will be directly connected. I use my iPad charger with a micro USB cable to power the Pi for troubleshooting and programming. Unplug your motors if you use a power brick so you will not run the risk of damaging your hardware while you are using the power brick.

-Sparx


#3

Hi Brian,

Sorry to hear about the trouble here. I have a few questions:

1). Are you using the ethernet cable? when you plug an ethernet cable in, do you see the lights on the ethernet port turn on and start blinking?
2). Is it possible to power the Pi with the 2A power supply; did you receive the Dexter Industries Raspberry Pi Power supply?
3). The Raspberry Pi version: does it have 4 USB ports or just 2? It might help us to troubleshoot what’s going on if you post a picture of your setup.

Best,

John


#4
  1. Yes, Ethernet plug lights work, green flashes then steady.

  2. I am powering the Pi with the 2A power supply from dexter industries.

  3. The Raspberry Pi has 4 sub ports.


#5

Great it looks like the Pi and the SD card are working properly. The problem is setting up a network, your Mac for some reason isn’t making a solid connection to the Pi or isn’t finding dex.local.

Are you able to ping dex.local? Is there a response from dex.local when you type ping dex.local in the command line?

I would try three things:

  1. Remove the wifi dongle on the Pi. You might need to restart the Pi after you do this.
  2. Turn off wifi on the Mac. Since you’re trying to connecting over ethernet, can you try turning off the wifi adapter on your Mac?
  3. Download and install Bonjour Browswer. This program can help you “find” bonjour machines like the Pi on the network. You can download it here: http://www.tildesoft.com/

Can you try these and let us know how it goes?


#6
  1. Removed wifi dongle on Pi, restarted Pi
  2. Turnded wifi off on Mac.
  3. Downloaded Bonjour Browser.

Screenshots attached.


#7

Forgot to add:

when I send the ping command, the response is:

cannot resolve dex.local: Unknown host

I want to reiterate, that this happens on ALL my mac computers (4 of them, 2 imac, 2 macbook air) I will dust off my 8 y.o. macbook next.

Thanks for your help.

Brian


#8

Brought out my old macbook for grins.

no changes

cannot resolve dex.local: Unknown host

That is 5 computers, no luck.

Brian


#9

Hey Brian, sorry for the continued frustrations. Can you send me a screenshot of what your ethernet advanced settings proxies looks like? To get that, go to Network Preferences, and select the ethernet adapter. Then select “Advanced…” and from the next menu, select the “Proxies”. When you see this tab, are anything on the list selected? IE does your computer have any special proxy settings setup?

And at the bottom, where it says “Bypass proxy settings for these Hosts & Domains” do you have “*.local, 169.254/16” entered?


#10

This is what mine looks like


#11

Also, can you run the following command on the command line:

ps aux | grep mDNS


#12

It is the same as yours.


#13

Do I run the command line:

ps aux | grep mDNS

in terminal?

Thank you,

Brian


#14

Hey Brian, yes, in terminal.


#15

Sorry, yes, in the Mac terminal with everything (the Pi, turned on) hooked up.


#16

when I run command in terminal I get:

ps aux | grep mDNS

Caitlins-iMac:~ caitlinbunkers$ ps aux | grep mDNS
_mdnsresponder 40 0.0 0.1 2470204 3516 ?? Ss Mon02PM 0:01.45 /usr/sbin/mDNSResponder
caitlinbunkers 2808 0.0 0.0 2423368 172 s000 U+ 2:10PM 0:00.00 grep mDNS
Caitlins-iMac:~ caitlinbunkers$


#17

What can I do?

My gopigo will not connect to any (5 different Macs) of my computers. I’d like to zither get a replacement raspberry pi board, ad card or just send it all back for someone at Dexter to solve. I’d be happy to pay for shipping both ways. This was a purchase for my 11 yo daughter to try and get her into programming.

Her interest is fading quickly…


#18

Hey Brian, I’m sorry for the slow reply. I’m also very sorry to hear your daughter is losing interest. I have two more avenues to try to solve your networking problem. Again, it sounds like your GPG is functioning correctly, the issues is making the connection.

Since we’re using a Mac, we can cycle Bonjour on it. This might help Bonjour refresh and find the GoPiGo. Again, I would do all this with the GoPiGo connected to wall power, over ethernet, both ethernet lights blinking. In the command line on the Mac, run:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist

This should disable bonjour on the Mac. Then run:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist

This should re-enable bonjour on the Mac. After you’ve run the second two commands, run:

ping dex.local

Finally, if cycling bonjour doesn’t work, you can assign a static IP address. This seems to have worked every time for mac folks having trouble connecting. This is a quick change on the SD card where you will be able to connect to an assigned IP address (something like 169.x.x.x where x are numbers, rather than “dex.local”.). The idea is that if your Bonjour software isn’t able to connect, either because it’s not working or something is preventing it from connecting on the network, we assign this fixed address and connect over it.

There is a short video here: (video - Mac): https://www.youtube.com/watch?v=q7mdXGxBuDI&list=PLGXEJ4Ye1qCMWziVrynnrIPpgfOr-2aj9&index=6


#19

woo hoo!

we are connected and completed the test.

My daughter is SO excited, on to mission two tomorrow night.

Thanks for sticking with us John!


#20

Hey bunkisland, that is the best news all week! So glad to see that it’s working and it’s really gratifying to see your success. Thanks for sticking with us through this!

Can you tell me, so we can help other folks: which step helped solve the problem? Did the sudo launchctl load commands work, or did the static IP address work?