[SOLVED] Usb drive not recognized


#1

GoPiGo3
Upgraded to Dexter OS Ver 2.1.1
The usb drive is no longer recognized, cannot save files from Bloxer menu.
And photos from the camera are not saved.
Tried reformatting Windows 10: FAT32 with drive name GPG1 (no spaces)
Same results.

Switching back to the Ver 1.1.1 SD card, the same usb drive did work to upgrade to Ver 1.3
It also works to save files.

Any suggestions?


#2

Switched back to Dex OS 1.3.2
Camera & USB drive both work fine.
Guess give up on Dex OS 2.1.1 for now?


#3

@wiltonkirk

Which drive do you have? The big black one? The tiny silver one? Or one of yours?

Cleo


#4

The big black one which says Dexter Industries on it.

Guess I should try a different one?

  - Mike Kirk

#5

Hi @wiltonkirk,

Do you have any other USB drives around to test with?

The best way to see if the drive gets detected is to head to Jupyterlab’s interface and check if there’s a drive in the side panel if you’re on DexterOS 2.x (make sure to click on the refresh button in the side panel) or use the web terminal on DexterOS 1.x to check if there’s a drive in /media directory.

Thank you!


#6

Different usb drive fixed it, now works both in 1.3 & 2.1
Remains strange that the black Dexter usb drive will work in 1.3 & not 2.1
But not important
Thanks!


#7

Hi @wiltonkirk,

We have identified the bug and we have fixed it. We are going to publish the image as soon as possible.

Thank you!


#8

Hi @wiltonkirk,

We have released the 2.1.2 version that fixes the drive issue. You can download the image by going to our website or by using this link here:
https://www.dexterindustries.com/download/dexteros

Please let us know if the bug with the black drive is mitigated.

Thank you!


#9

It works!
Many thanks.


#10

And thanks to you for bringing this to our attention!
Cleo


#11