[solved] VNC client does not transmit mouse clicks


#1

I am running the VNC client on a Win 8.1 laptop. I can move the move pointer around the Pi desktop but the desktop does not respond to mouse clicks. I have to touch my laptop screen (touch screen comes with this laptop) to click on icons. Is there a way to set the VNC controls for mouse clicks?


#2

Hi Bob3280,
The VNC in the browser does not work well with touch screen laptops and is there specifically with Google Chrome as it takes touch as the default input for noVNC which is what is running on the RaspbberyPi to give the browser interface to the VNC server. Can you try another browser like Firefox. Or you can use VNC viewer: https://www.realvnc.com/download/viewer/ to use it ( Use dex.local:1 as the address in VNC viewer.

This bug is not on our image/software end and is in the implementation of noVNC. If the noVNC instance gets updated in the future and this bug gets removed, we’ll update the image too.

Do let us know if this helps.

-Karan


#3

Karan,
Many thanks for your helpful suggestion. Firefox does transmit the mouse clicks. I will try IE and see what happens there.

Bob


#4

I have the same problem and after reading Bob3280 message I tried just using my touchscreen (on SurfacePro using Chrome) and VNC transmitted the click.

Kevin


#5

@k_mac87,
What’s the exact problem that you are having. Was the surface able to send click when you were using a mouse. What VNC client were you using.


#6

This issue should be solved with a new software update for Raspbian for Robots!


#7