SPI - No response


#1

Hi - Just purchased a brickpi3 and trying to get things going on it. I have installed brickpi3 and updated the firmware. When running the command below upon bootup of the brickpi3, everything looks good and i get info stats being passed back by the brickpi3.

sudo python /home/pi/Dexter/BrickPi3/Software/Python/Examples/Read_Info.py

However after about 10-20 seconds, i lose connectivity to the brickpi3 from the raspberry.

Doing some debugging, connectivity seems to be lost at the same time when the below is logged in /var/log/messages:

Dec 23 09:31:37 dex kernel: [ 43.400341] gpiomem-bcm2835 3f200000.gpiomem: gpiomem device opened.

This behavior is repeatable.

Any tips?

Cheers,

Jason


#2

Hey @lo_jason, sorry to hear about this, but a few followups:

  1. How are you powering the BrickPi3 and Raspberry PI?
  2. What operating system are you building on?
  3. And when you say you “lose connectivity”, what behavior are you seeing? Are you running a program that stops responding?

#4

Hi Johnc,

  1. have tried - powered by usb; powered by battery pack and powered by usb and battery pack - all same symptoms
  2. pi@dex:~ $ uname -nr
    dex 4.4.34-v7+
  3. typically i run two terminals:
    one terminal running:
    watch -n1 sudo python /home/pi/Dexter/BrickPi3/Software/Python/Examples/Read_Info.py
    another terminal running a tail on /var/log/messages
  • read_info displays information up to the point where this message “Dec 23 09:31:37 dex kernel: [ 43.400341] gpiomem-bcm2835 3f200000.gpiomem: gpiomem device opened.” registers on /var/log/messages then read_info.py displays “spi no response”

I can reboot and run the two terminals with read_info and tail of the /var/log/messages and get initial connectivity from rasp pi to brickpi then get the spi no response when the above message get logged on /var/log/messages

Any tips - i got this brickpi for my kid for Christmas and he’s itching to jump on but at this point i can even get it going.

thanks again

Jason


#6

Hi guys,

Just wanted to follow up on the issue that I am experiencing - any help would be appreciated…

thanks

Jase


#7

Hey @lo_jason, @Matt is looking into this. Sorry for the delay!


#8

No worries… thanks for the heads up.


#9

Hi guys,

Just wondering if there’s was any gains made with this particular issue that i’m having?

Cheers,

Jason


#10

Try updating Raspbian for Robots. Run “DI Software Update” on the desktop. After updating the software, update the BrickPi3 firmware.

With a Raspberry Pi 3 running the latest Raspbian for Robots image, the BrickPi3 seems to be working perfectly for me. The BP3 is running FW version 1.4.6.