Ssh connection refused

Hi all,
I am new to the GoPiGo. After the assembly is done, I inserted the sd card supplied by Dexter Industries. When I ssh into raspberry from my ubuntu machine with the ethernet cable, it gave an error connection refused. Here is the output of ssh:

cheok@ThinkPad-X240:~ ssh -vvv pi@ OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to [] port 22. debug1: connect to address port 22: Connection refused ssh: connect to host port 22: Connection refused cheok@ThinkPad-X240:~

I have enabled ssh on the raspberry and i can ping it:

cheok@ThinkPad-X240:~ ping PING ( 56(84) bytes of data. 64 bytes from icmp_seq=1 ttl=64 time=0.049 ms 64 bytes from icmp_seq=2 ttl=64 time=0.030 ms 64 bytes from icmp_seq=3 ttl=64 time=0.066 ms 64 bytes from icmp_seq=4 ttl=64 time=0.067 ms 64 bytes from icmp_seq=5 ttl=64 time=0.061 ms 64 bytes from icmp_seq=6 ttl=64 time=0.035 ms 64 bytes from icmp_seq=7 ttl=64 time=0.039 ms 64 bytes from icmp_seq=8 ttl=64 time=0.066 ms 64 bytes from icmp_seq=9 ttl=64 time=0.069 ms 64 bytes from icmp_seq=10 ttl=64 time=0.066 ms ^C --- ping statistics --- 10 packets transmitted, 10 received, 0% packet loss, time 8999ms rtt min/avg/max/mdev = 0.030/0.054/0.069/0.017 ms cheok@ThinkPad-X240:~

Please advice.


Sorry I got the wrong in address.

Hi Anthony,
Just wanted to confirm that the problem is solved and it was just a case of incorrect address.