Step 4 in setup instructions fails to work


#1

I have tried installing Arduberry using the setup instructions at:

http://www.dexterindustries.com/Arduberry/getting-started/

I have completed steps 1 to 3

When I attempt sudo ./install.sh I receive "bash: /home/pi/Desktop/ArduBerry/script/install_jessie.sh: No such file or directory.

I note the file clearly exists however nowhere in the instructions does it list this error or how to fix it. I have tried installing to the Desktop and also within Documents. I cannot find anything in the instructions as to specifically where to clone the Arduberry repository to, or why sudo ./install.sh.


#2

Hi @swhobbs2000,

It looks like you have cloned the ArduBerry repository to a different folder. If you have a close look at step 3 here, it has an image showing the ArduBerry repository being cloned to Desktop.

Please remove the existing ArduBerry Repository that you have cloned and clone it again from Desktop and run the install script, following the steps given here.

Do let us know if this helps,
-Shoban


#3

Hi Shoban,
thank you for your help. Unfortunately I have tried recloning to Desktop, following your steps and receive exactly the same error. The script fails to install.
Regards,
Steven


Zero programmer options available under Programmer tab
#4

Hi @swhobbs2000,

Can you post a picture of the error that you are getting when you run the install.sh. Can you also post a picture of what happens when you do the following:

  • Go to /home/pi/Desktop/ArduBerry/script and enter ls to list the files in the script folder and post a picture of it in your reply.

-Shoban


#5

Hi Shoban
attached is a screengrab showing the relevant info.
I confirm that I have a folder Arduberry in the /home/pi/Desktop/ folder.
I then type sudo chmod +x install.sh and hit return.
I then type sudo ./install.shI then receive bash: /home/pi/Desktop/Arduberry/script/install_jessie.sh: No such file or directory.
This error occurs 100% of all of the 22 attempts I have made at cloning Arduberry into Desktop and running the script. I can find no reference to this error in Step 4 of the instructions or anywhere else in the instructions.
Regards,Steven


#6

Hi @swhobbs2000,

Sorry for the delay in reply, I wanted to test out your problem. I tried with a fresh Raspbian image and I didn’t face any problems.

It looks like the folder name in your computer is Arduberry and not ArduBerry. So that seems to be causing the trouble. At step 3 here we have mentioned as Arduberry, thanks we will get it changed to ArduBerry .

So goto /home/pi/Desktop and run sudo mv Arduberry ArduBerry
and then follow the steps 4 and 5 from here.

Please let us know if this helps,
-Shoban