Sudo ./ error line 11

I am trying to get my grovepi to work with my Raspberry Pi 3+, but am getting an error when following the instructions:

When running step 5, I get this error:

./ line 11: /home/pi/Dexter/lib/Dexter/script_tools/ No such file or directory
Special thanks to Joe Sanford at Tufts University. This script was derived from his work. Thank you Joe!
./ line 48: feedback: command not found
I2C-dev already present
i2c-bcm2708 already present
spi-dev already present
./ line 68: feedback: command not found
i2c1 already present
i2c_arm already present
adduser: The group `i2c’ already exists.
./ line 86: feedback: command not found
./ line 87: /home/pi/Dexter/lib/Dexter/script_tools/ No such file or directory
./ line 88: create_avrdude_folder: command not found
./ line 89: install_avrdude: command not found
done with AVRDUDE for the GrovePi

I have tried:

  • Update and upgrade the code for the raspbian os
  • To update the firmware (got another error)
1 Like

Updating the firmware only works on the Pi-4.

What base O/S are you using?

1 Like

ah, ok. that makes sense. I use Raspbian. But I found a workaround to get to my end goal: I skipped all the installation and followed the instructions from these guys: for Python. That worked :tada: So my problem sort of disappeared (for now). Tnx for getting back to me.

1 Like

Hello @erik
Your GrovePi isn’t fully installed and you may run into other issues.
I’ve updated the installation steps on the website, so thank you for bringing it to my attention.

Please run:

cd ~/Dexter/GrovePi/Script 
bash ./

to complete the installation.


That’s not true. Any Pi can update the GrovePi firmware now (except I think the Pi 1)

Awesome, many thx Cloe, you’re the best.


I’m sorry, I just heard from you

I thought he was referring to updating the Pi.