Sudo Password gopigo jupyter rasberrypi 4

I’m trying to install espeak and aplay in order to make it talk but it keeps asking for a sudo password. I’ve run the Jupyter notebook password to reset it but It’s not working. gopigo error

1 Like

What operating system are you using with what device? A GoPiGo?

I’m using the gopigo os with a raspberry pi4.

1 Like

What password are you using?

The release announcement and the forum topic about that O/S mentioned Jupyter specifically and how to get root access from within a Jupyter command shell.

I’m trying to install to
A module to play sounds. I can’t remember the name of it right off the top of my head but its in the tutorials and projects of gopigo for using a speaker and making it speak. When I try to do the sudo command to install the module it asks for a password that I don’t know. It asks for a sudo password and I’ve tried to reset the password through Jupiter but it still won’t work.

1 Like

See the previous message.

Have you looked up the password in the GoPiGo release posting and on the forum?

Here are the GoPiGo O/S release notes:

Let me know if this helps.

It did. Thank you. I had missed the password when I skimmed through it. Now I can run sudo commands. I’m just trying to make it talk through some headphones but right now its still silent. It does have the espeak package though and I know its updated.

1 Like

You might want to search these fora for “espeak” as there are a number of entries from people who used that package, had issues, solved them, and reported result here.

I’ve never done that so I can’t help you, but I know there’s lots of help here on the forum.