Temp/ Humidity sensor Grove Pi NOT working -1C -1% Humidity

grovepi
dht

#1

:cry:

Blockquote

I’m kind of new at Grove pi and I have a problem. I have a temperature and humidity sensor and I followed the instructions and it left me with -1C and -1% Humidity. I installed the newest version of NOOBS and everything but it still didn’t work. Please anyone I need help ASAP.


#2

Hi @squirrelheat1,

Can you first tell us the version of the GrovePi firmware you currently have? And also the code you are trying to run.

Thank you!


#3

I am running version 1.2.7 of GrovePi
And I’m using the code that was downloaded called advanced temp and humidity


#4

Hi @squirrelheat1,

Okay, having the 1.2.7 version on it should be fine. Just to make it very clear, you are running this script:

Now, depending on what DHT sensor you’ve got, you have to change the type of the module on line 53. A mismatch between what you select in the script and what you actually have can manifest in the way you described.

Let us know if this fixed your problem.

Thank you!