Terminal problem


#1

i have a problem with the go pi go on not being able to connect it to my mac. i have check every thing per your instruction on the website but it still does not connect. the usb ethereal cable said that it is connected but when i went to the terminal and type in <ping dex.local> ,the msg shows <ping: cannot resolve dex.local: Unknown host>.

please reply me soon thank you .


#2

I just want to confirm: you’ve powered up the Pi, connected it to your mac directly over ethernet. The ACT and PWR lights on the Raspberry Pi are on, and the ACT light blinks. The LED’s on the ethernet port light up. Can you confirm this is all true?

If that’s true, and you can’t ping dex.local, there are a few things we can try:

1). Turn wifi on your macbook off, and remove the wifi usb adapter on your Raspberry Pi. Give it a minute, and then try to ping again.
2). Install a program called “Bonjour Browser”, this is available for Mac here: http://www.tildesoft.com/ There is a ling for download at the bottom of the page. You should install this, run it, and click “Reload Services” This should search the network (ethernet) to find all services on your network, you should see “dex” on there.

John


#3

Alternatively you can connect to the ip address of the GoPiGo by opening a browser window on your Mac and entering the ip address of the GoPiGo and hitting Enter. This will open the web page on the Pi and give you a choice to open the VNC interface or the Terminal interface.

-Regards


#4

hi guys, i have tried both of ur solution but it did not work i am having a problem with it connecting still so i do not know what is going on

pls reply me soon thankyou


#5

Hello go pi go 1234, I have some more questions.

  1. Are you using the latest DI Image Raspbian for Robots? If you’re using an SD card we sent you, what date is on it?
  2. Are you using a Mac or PC to connect? In your first post, it said Mac, just want to confirm.
  3. Are the Power and ACT Lights Blinking?
  4. Are you powering via the USB Raspberry Pi Power Supply?
  5. Which version of the Raspberry Pi are you using?

Best,

John


#6

I’m having the same problem.

  1. I am using the sd card you sent with a date of 2015.11.09
  2. Mac to connect
  3. Power light on steady, ACT light blinks for a while then off
  4. Using the AA battery pack
  5. I’m not sure what version of Raspberry Pi that is being used. How can I check?

I have tried to connect using a web browser as well. No luck with that.

Thanks for your help.

Brian


#7

Before we get too far off on this thread; bunkisland we’re helping you on a different thread. go pi go 1234, still waiting to hear back about our questions.

John


#8
  1. I am using the sd card you sent with a date of 2015.11.09
  2. using Mac to connect
  3. Power light on ,act on too
  4. Using the AA battery pack and adapter
  5. raspberry pi i am using model B

pls reply soon^_^


#9

Do the power light and ACT blink at all when you turn the Raspberry Pi on. Can you insert the SD card in your computer and tell us what you see there. Does the SD card show up empty or with some data.

-Karan


#10

Also as a followup to Karan’s question: for the purpose of connecting to the Pi, we recommend using a 2A power supply such as the Raspberry Pi power supply.


#11

now when i try to ping the ip address it worked but now a new problem came out when i go to my chrome web browser and enter dex local/ it did not worked

pls reply soon


#12

even when i tried entering ip address instead of dex local/ it still did not work

pls reply soon


#13

i even considered static ip and it worked but the problem is when i go to my browser and type in dex.local it did not work.BTW i am in singapore not US would it make a diffrence?

pls reply soon


#14

Your location wouldn’t make much of a difference. If you’re using a VPN, we recommend you shut it off.

So, you have a static IP address and it responds to ping. What was your PC/Mac address and what was the IP address you asigned your Pi?