The motors not working


#1

After first assembly of GoPiGo, after switching on,

The pi pwr led is red, activity is blinking, but the motors are not running.

The motor wires are connected.
Using the default BrickPi 2014.03 SD card which came with the kit.

Any thoughts on what is happening.


#2

Hi,
Can you give us a few more details about what you have tried.

Are you powering the GoPiGo with batteries and have voltage greater than 9V and have you tried the basic test script.

-Karan


#3

yes powering with batteries(8 new AA).

I followed the instructions on this page http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/1-assemble-the-gopigo/assemble-gopigo-raspberry-pi-robot/

Then powered on.
the power led on the gopigo is greeen. the pwr led on Pi is red.


#4

Hi,
Can you run sudo i2cdetect -y 1 and post the output that you get. Also, what happened when you sent the “w” command on the basic test python example?

-Karan


#5

i2cdetect -y 1

it has 08 at 8.

I have disconnected the motor cables now, because used micro usb to connect to the pi.

screen shot attached


#6

pi@raspberrypi ~/Desktop sudo i2cdetect -y 1 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- 08 -- -- -- -- -- -- -- 10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 70: -- -- -- -- -- -- -- -- pi@raspberrypi ~/Desktop

pi@raspberrypi ~/Desktop ls ArduBerry midori.desktop BrickPi ocr_resources.desktop BrickPi_C python-games.desktop BrickPi_Python scratch.desktop BrickPi_Scratch shutdown.desktop debian-reference-common.desktop Version GrovePi wiringPi idle3.desktop wolfram-mathematica.desktop idle.desktop wpa_gui.desktop lxterminal.desktop pi@raspberrypi ~/Desktop


#7

Also not able to connect with VNC.
So how do I update from command line shell.
Cannot find the gopigo directory.

Also no icon for upgrade if I connect a monitor.


#8

Also how to delete the attachment in message “November 18, 2014 at 4:29 am” - if possible can you delete it.
Thanks


#9

Hey GG, the motors won’t work unless you actually call a program.

It looks like you need the updated image file first, that will have all the latest software and updates on it, as well as the update button.

AFter you’ve installed that, you should find the GoPiGo directory on your desktop. That will have the latest software examples, including one that runs the motors.


#10

How to get the update image, can you point me to the instructions.

Is it option 2: in this page http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/sdcard/

Is this command required to be run on the pi terminal, (also what is to be selected?)
sudo raspi-config

Also how to delete an attachment in a previous post.

Thanks


#11

Hi GG,
If you are not using a Dexter Industries SD card, we’ll recommend you to download the image and follow the Step 2 of the http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/sdcard/. This is the easiest way to get started as it comes with all the setting and packages already installed.

If you want to modify your own custom Raspbian Image, then you should follow Step 3.

I’ll recommend using step 2 because there is nothing much which can go wrong there.

-Karan


#12

yes, i am using the SD card which came with the kit, not sure why it had BrickPi sticker on the SD card. Will try with step 2 and let you know.


#13

Hi GG,
Looks like you got an older SD card. Let us know if using the updated images helps you.

Sorry for the troubles.

-Karan


#14

Thanks got it working.