Trouble connecting to Mac


#1

I’m having the same problem as bunkisland (http://www.dexterindustries.com/topic/unable-to-connect-on-mac/). Specifically, when I tried to ping dex.local I got the following response: “cannot resolve dex.local: Unknown host.” I followed John’s advice on setting a static ip, using the YouTube video: https://www.youtube.com/watch?v=q7mdXGxBuDI&list=PLGXEJ4Ye1qCMWziVrynnrIPpgfOr-2aj9&index=6.

I pinged the new static ip, and got successful responses. HOWEVER, I then tried connecting via Chrome (and FireFox) to dex.local/ and had no luck. I also tried pinging dex.local and no luck. Did I somehow miss a step? How is my computer supposed to associate the new static ip with dex? Just for kicks, I tried connecting through my browser to the new static ip and that also didn’t work.

My 9-yo son is breathing down my back, so any help would be appreciated!

Thanks,

Adam


#2

Hey Adam,
Sorry to hear that you are having trouble with the networking setup.

Are you using a Dexter Industries SD card or did you download the image and what is the date on the image/SD card. Which model of the Raspberry Pi are you using and were you able to connect the Raspberry Pi to the wifi. Also, did you try following all the steps on the page which helped bunkisland http://www.dexterindustries.com/topic/unable-to-connect-on-mac/.

-Karan


#3

Thanks Karan. We received the Dexter SD card with the GoPiGo in October as part of your GoBox Kickstarter campaign. We have the Raspberry Pi 2. I tried removing the wifi dongle and turning off the Mac’s wifi. I did not try messing with Bonjour since it sounded like the static ip solution made that moot. I have not been able to reach vcn so I haven’t moved on to establishing wifi connectivity.


#4

Hey aslote,

Again, sorry to hear about the challenges of setting up the wifi. I have a few ideas:
1). I would check that the Raspberry Pi is turning on correctly. This is what a succesful bootup looks like: https://youtu.be/TORys5PpWM8 You just to make sure you don’t have a corrupted SD Card.
2). Make sure you’re powering using the Raspberry Pi Power Supply. We will put it on batteries later.
3). If we’re sure we’re powering up correctly and we’re on the network, try using Fing to find the Raspberry Pi. It might be on the static IP, and it might not be showing up on your network at all. The Fing software will help you see what’s on your network, and help you find the location of the Pi. We have a tutorial for it here: http://www.dexterindustries.com/howto/fing-tool/


#5

John,

  1. Yes, my bootup was successful.
  2. I’m using the iPhone charger, which has the same output as the Dex charger (5V, 1A).
  3. Fing is for finding a device on a WiFi network, but I can’t get the GoPiGo onto my WiFi network. I can’t ping dex.local.

I just tried connecting the GoPiGo to a second Mac, with exactly the same results. I can ping the static ip, but I can’t ping dex.local in terminal or connect to dex.local/ via a browser.


#6

Hey aslote,
What happens when you enter the static ip in the browser address bar. Do you get a menu there? Can you try pinging raspberrypi.local and see if that gives any output.

-Karan


#7

Also just to note:

“3) Fing is for finding a device on a WiFi network, but I can’t get the GoPiGo onto my WiFi network. I can’t ping dex.local.”

Right, of course. And I’m asking you to use Fing to see if your GoPiGo is on the network or not. Just because you can’t ping it doesn’t mean it’s not on the network under a different name or a different IP address.

As Karan recommends, you should try to see if you can connect to the fixed IP address, or the IP addrss that Fing sees on the network for your Pi.


#8

Sorry, what I meant was that I wasn’t able to get past the ping dex.local or http://dex.local step, so I wasn’t able to reach vnc and connect the GoPiGo to my network. So Fing can’t find it.

I am able to ping raspberrypi.local successfully. However, when I put the static ip in my url, it comes back with “xxx.xxx.xxx.xxx refused to connect.”

Adam


#9

Hey Adam, is there something we’re missing? We’re a little confused here: you got the SD Card from GoBox, but they have a Pi 2 (we shipped B+ with the GoBox), and the ping is responding to raspberrypi.local (the firmware by then should be responding only to dex.local). Can you shed a little bit of light on how you got the various parts you’re using?

Thanks, sorry for the confusion here.


#10

I actually didn’t get the GoBox - I just got the bare bones GoPiGo 2. I already had a Raspberry Pi 2 from Adafruit.


#11

Ok, great to get a little more detail. What are you using for your SD card? Did you buy that from us? If so, when? If so, what date is on the SD Card?


#12

Yes, it’s from you. The MicroSD adapter says “2015.03.20”. You shipped it in October 2015.


#13

Ok, great. That clears everything up. Indeed the hostname of this version of software is “raspberrypi.local” We made the switch with the latest software right after you bought the card, in Nov 2015. The reason the tutorials aren’t working for you is that you have dated software.

Your best, easiest bet is to start over on the SD Card and update the software. We have directions on how to do that here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

Once you install the new software, you should be able to use “dex.local” and move forward pretty easily with the setup directions.


#14

Thanks John. I’m in Terminal and, since I’m using El Capitan, typed in “dd bs=1m if=2016.03.28-Dexter_Industries_wheezy.img of=/dev/rdisk2”. However, I received the message “dd: /dev/rdisk2: Permission denied”. It did not prompt me for my password. In case it’s of any importance, note that I did not erase the old card before starting.


#15

Hey aslote,
can you run the dd command with sudo, which should give it the permissions sudo dd bs=1m if=2016.03.28-Dexter_Industries_wheezy.img of=/dev/rdisk2. I think is mentioned in the tutorial here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/.

-Karan


#16

Thanks Karan, that worked and everything is up and running just fine! Can’t wait to work with my son on this now. Just one FYI: you have special instructions for El Capitan users here http://www.dexterindustries.com/topic/raspbian-for-robots/#post-72091 that doesn’t include “sudo” at the beginning of the command (that’s why I didn’t include it), so you may want to add that to the post to make it clear.

Thanks again,

Adam


#17

Great to hear that it worked for you Adam. Hope that you and your son have a great time with the GoPiGo. Do share any interesting projects that you do with the GoPiGo. We’ll update that other page asap.

-Karan


#18

Hey aslote, Karan, I just updated it and added sudo so the next person that finds it gets the correct advice. Thanks so much for pointing this out!