Troubleshooting error?


#1

Hello…I have been having problems running some of the basic sensors with my GrovePi. I ran the troubleshooter, and it appears there are errors in “dependencies”. Are these in fact errors, and if so, how do I correct them?

Thanks, Steve


#2

There are many type of trubleshooting error such as VOL, Mute, or A/V do not work, Batteries dislodged or drained,Remote doesn’t work with TV,Device not active, Signal not being received,Device not programmed, TV settings have changed, Loose connection and Red LED blinks 5 times when CH+/- and OK pressed.
but the general troubleshooting error occurs in Loose connection you can solve by Check the Optical Network Terminal (ONT) or splitter connections are secure.

please mention exactly which type of troubleshooting issue in on your system


#3

Thanks for replying. I have been unable to get something as simple as LED_fade to work (see my previous posts titled: " LED Fade not working

Running troubleshooting yields the following possible errors:

Check for dependencies

python 2.7.13-2 install ok installed
python-pip 9.0.1-2+rpt2 install ok installed
git 1:2.11.0-3+deb9u4 install ok installed
libi2c-dev 3.1.2-3 install ok installed
python-serial 3.2.1-1 install ok installed
python-rpi.gpio 0.6.5~stretch-1 install ok installed
i2c-tools 3.1.2-3 install ok installed
python-smbus 3.1.2-3 install ok installed
dpkg-query: no packages found matching arduino
dpkg-query: no packages found matching minicom
scratch 1.4.0.6~dfsg1-5 install ok installed

find: ‘/run/user/1000/gvfs’: Permission denied
find: ‘/proc/632/task/632/net’: Invalid argument
find: ‘/proc/632/net’: Invalid argument
wiringPi Not Found (ERR)
find: ‘/run/user/1000/gvfs’: Permission denied
find: ‘/proc/632/task/632/net’: Invalid argument
find: ‘/proc/632/net’: Invalid argument
I2C still in blacklist (ERR)
SPI still in blacklist (ERR)