Unable to boot Raspberry PI 3B+(Ubuntu 19.04) with GrovePI+

Hi,
Has anyone tried Ubuntu 19.04 on Raspberry PI 3B+? Without GrovePi+ shield, the board boots up and I don’t see any problem. However, when i connect GrovePi+ shield and power-on, the system doesn’t boot.
The boot configuration has i2c_arm enabled, i.e in the file boot/firmware/config.txt dtparam=i2c_arm=on is set by default.
Do I have to update anything else to get it working with GrovePI??

Thanks,
Bindu

I think you are in uncharted waters. We never tried the GrovePi on Ubuntu. It should work, although it’s possible that you may need some modifications.

Still, you might try the 2 following things:

  1. Attach the GrovePi shield after the Pi has booted up.

  2. Connect the GrovePi to the Raspberry Pi with jumper wires. Make sure you only connect the power supply, the ground, and the I2C pins. If it does work, then see if adding the SPI connection makes it fail.

You can look at the hardware layout of the GrovePi here:

Thank you!

I have been running Ubuntu - 18.10 on Raspberry PI 3B+ with GrovePi and that works fine. Now, I plan to use the latest release of Ubuntu available for Raspberry PI and that’s when I see the problem.

I tried to disable SPI in the boot config, but that didn’t help either.

Thanks,
Bindu

Update:

I tried option no. 1 (Attach the GrovePi shield after boot) and this works fine.
Could I get any information on the boot config changes required to get this setup working on hard boot?