Unable to connect to robot after the latest update


#1

Hi,

I updated my robot last week and was able to program on it and do logging etc. However, since then I am unable to do any programming. I have re-installed the update a couple of times, and I see the wi-fi and can connect to it. However, I cannot go to mygopigo.com or 10.10.10.10.

Lalitha


#2

Hello @lagnihotr

Did you do a full shutdown between each update?
Basically, update, shutdown, boot up again.

Please confirm,
Cleo


#3

Yes… Update, shutdown, and boot up again. I can see the wifi network and join it as well. However, cannot connect to 10.10.10.10.


#4

Also, the shutdown doesn’t seem to be working. It keeps blinking… I have to pull the battery out to shut the robot down.


#5

Yes, you are right. After an update, you need to pull the batteries once the purple light shows up.

Let me investigate a bit on my side. You’ve done everything right.

Cleo


#6

Oh, what version were you updating from? And were you updating to 1.3.2?


#7

If it works we can do a video call so you can see what I am doing as well. I would like to figure this out at the earliest!


#8

Not really sure which version. The latest? Which has features for logging etc.


#9

The latest version 1.3.x has logging in it. But I also need to know which version you had on the robot before the update.


#10

I really don’t know… Lisa, do you know what version we had on our robots before I updated?


#11

Lisa says, I am not 100%, but likely 1.2.


#12

I’ve tried four times to update from 1.2 to 1.3.2 Each went through without a glitch, so it has been no help.
Are you getting logs on a usb drive? I’d be interested in seeing the logs that are System logs.

Cleo


#13

Here is the latest logs…

34_Systemlog_2017_12_12__21_12_38.txt (234 KB)


#14

Thanks @lagnihotr
I can see what the error is, although not the cause of it.
Now I can work on a solution.

Cleo


#15

Hello @lagnihotr

Lisa will probably share this with you but in case you read this before talking with her.
Can you find an SD card that has a native 1.3.2 on it? Directly from the image, not one that has been upgraded to 1.3.2.
Can you boot up the non-working robot with that SD card? I believe it will fix the robot. If it doesn’t, I would need the System log from this attempt.
If it works fine with that SD card, do a shutdown, swap the card to the previous, non working one, and boot up again.

please let me know how it goes.
Cleo


#16

I will be able to find an SD card in Boston tomorrow. All the robots in HEAF are having the same issue. The class couldn’t happen today because of this.


#17

@lagnihotr
I’m really sorry to hear that about the class. My apologies.
I tried really hard to reproduce it to understand what’s happening, and have not been able to get the problem to happen. Yet there is a problem for sure if all your robots have the issue (even if only one did).

Cleo


#18

I understand how these things go… It is all right. I will try the SD card in the morning and let you know how it goes.

Lalitha


#19

@lagnihotr,

Any update?


#20

Hi,

So I got a copy of the data on their SD card and just loaded it up on my machine… Didn’t work :frowning: It didn’t want to copy “overlays” into my sd card. Going to HEAF tomorrow and they have a brand new rover. I will put that SD card in mine and see what happens…

Lalitha