Update problem - GoPiGo


#1

I just assembled the GoPiGo. While for the SD card, I am going for the option 1 for using the SD card from Dexter Industries, and I am using the battery for the robot power up. For the connection of the robot, an Ethernet cable was used to connect to the cable and successfully connected.

However, when I came up to update the raspberry pi before the first use and follow the instructions, I know my computer had connected to the internet and the robot is connected to my computer. And I have no clue how to open the VNC hence the DI Software Update icon on the desktop.

Anyone know and if can give a help would be great.


#2

Sure, happy to help. Do you have VNC installed on a computer? VNC let’s you open your Raspberry Pi from another computer (like a Mac or PC).

You can download VNC, the light version, here: http://www.realvnc.com/

Then, once this is setup, you should be able to login with VNC, using the address “raspberrypi.local:1” (password is raspberry)

And that should take you directly to the desktop.


#3

Thx for our help. But while after I processed to the Desktop and click on the DI software update, the following picture shown up. What’s happening and what shall I do?


#4

Hey,
Looks like the script is having problems connecting to the internet. Can you just make sure that the pi is connected to the internet and run something like ping google.com on terminal and see if the pi is really connected.

-Karan


#5

Hi,

Thanks Karan. I think you are right as I followed your suggestion to type in ping google.com at the terminal and the attached is the result.

In that case my pi seems like can not connect to the internet, so may I ask how my pi can connect to internet? any settings required?

P.S. Currently my pi is using an Ethernet to connect to my computer. I was successfully login, at the same time my computer is able to connect to internet through wifi.


#6

Hey,
You should follow this tutorial to set up wifi on your Pi so that it can connect to the internet: https://learn.adafruit.com/adafruits-raspberry-pi-lesson-3-network-setup/setting-up-wifi-with-occidentalis .

-Karan


#7

Thanks Karen, it works now. :slight_smile: