Update snag


#1

I’ve been following along in the directions and reached the point where it was time to update the software. I clicked “Update Raspbian” and it seemed to be doing fine, then got stuck when it reached the Samba server and utilities. It has been on that same screen for the last 5 minutes with no change. How long should I wait before giving up and rebooting?

Well, now I have a different question. My home Internet connection flickered and interrupted the update. Now the icon for the DI Software Update on the VNC screen has a blue clock image attached to it. When I try to click the icon, the black terminal window opens up and says that the GoPiGo is not connected to the Internet. But I have pinged and it is connected to the computer with the Ethernet cable, and it had to be connected for the VNC screen to open in the first place. And I can’t reconnect through the WiFi icon, because the field on the Adapter is blank and won’t let me type in “wlan0”.

Could the interruption of the Internet signal have caused damage to the files on the SD card? I already checked on ordering a new card, but they are Out of Stock.

These are some of the error messages from the Troubleshooting log:

checking I2C bus Error Could not open file “dev/i2c-0” no such file or directory

Checking for firmware version and CPU speed and voltage
IO Error: [Errno 2] No such file or directory


#2

Scostner1, often if the update is interrupted, it can cause problems.

So the “DI Software Update” software icon should have a blue clock next to it. If the adapter is blank, it is not detecting the wifi dongle. Can you try to remove and replace the wifi dongle. If that doesn’t work, try two things:
1). Reboot the Pi.
2). If that doesn’t work, in a terminal screen with the wifi dongle plugged in, type in “lsusb” in the terminal. Is the wifi dongle listed there?


#3

Yes, the software icon has the blue clock next to it.

I have tried removing and replacing the WiFi dongle, but when I tried typing “lsusb” in the terminal it said - “lsusb” is not recognized as an internal or external command, operable program or batch file.

I reconnected using the Ethernet cable and was able to pull up the VNC screen, but the wpa_gui window says “could not get status from wpa_supplicant” under the Current Status tab. It still does not display anything under the Adapter tab either.

What should I try next?

I noticed that the SD cards seem to be back in stock, so I have gone ahead and ordered a replacement, just in case this one is corrupted beyond repair.


#4

Hey scostner1, I’m confused about what could be happening now. I’m not sure why lsusb could be possibly not showing up, I’m lost.

Before you order a replacement, you can try to install the image yourself. We have directions on how to do this here: http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/

Does this look like something you could try to do?


#5

John - You are brilliant! The re-imaging of the SD card, combined with disconnecting and reconnecting the WiFi dongle got everything reestablished. Just completed a successful demo and it performed properly. Thank you!!!


#6

Fantastic, glad we got this solved! That’s great news.

We’ll start working on a better way to recover from aborted updates. I don’t know how, exactly, we’ll do it, but we’re working on it. Thanks for your patience!