Update software


#1

hello, i’m a frensh teacher and i dont speak english very well…
One year ago, i have install the software on my raspberrypi, install before Raspbian. Everything is all right, but for example, barometer high accuracy, gps, ultrasonic_ranger,barled… doesnt work because the software is not updated. Led, switch, temphum… are all right.
I dont have the link dexter on the desktop to make an update.

How can i update the software ?
Should i install the software from the begenning ?

Thanks !


#2

Hey Seb,

If your software is over ea year old, I would recomend downloading and installing a new version. We’ve made some BIG leaps in the software over the last year. You can get it for free, and we have directions on how to do that here:

http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

Here’s a quick preview of how the latest works: http://www.dexterindustries.com/raspbian-for-robots/


#3

Hello,
Thank u very much ! It’s very interesting.
But i dont want to burn my sdcard because i spent a lot of time to install a lot softwares like Apache server, i sent a lot of time too to configurate a lot of things.
I just want to update dexter software without changing my sdcard and its configuration.
i just want to use in python sernsors like : gps, barometer high accuracy, barled and others that has been updated since one year.
Can u please explain me how can i do ?

Thank u


#4

You would update the individual software direectory using git. If you’re using the GrovePi software, you would change directories to the GrovePi directory, and then run sudo git pull

That should update the individual files!


#5

Thank you John. If I understand, I just have to do :

cd GrovePi

and

sudo git pull


#6

Correct. Does it work?


#7

I tried the same sudo git pull. It does not seem to work. I still have a firmware version of 1.2.2


#8

@reunny > you also need to run the firmware update script to change the firmware, and not just the git pull

In your GrovePi directory, there should be a Firmware folder. Inside it you will find firmware_update.sh

sudo ./firmware_update.sh or sudo bash firmware_update.sh to run it.

Should this complain about not finding gpio, which currently happens on a Jessie card (and not a Raspbian for Robots Jessie), you will then need to run two other scripts

wget https://raw.githubusercontent.com/CleoQc/Raspbian_For_Robots/master/upd_script/update_GrovePi.sh
wget https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/update_GrovePi_Firmware.sh

I’m giving you links to my own repo because there’s a typo in the official one that stops it from running. The typo will be fixed within hours. And when it’s done you can use this link instead
https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/update_GrovePi.sh

Executing both of these scripts worked for me, on a brand new “pure” Jessie (May 10th image)

Hope this helps!