Update the Firmware on the GoPiGo3


#1

I initially had issues with the GoPiGo3 and they were fixed with a firmware update on DexterOs that was successful. Read_Info.py worked but later it stopped working saying I needed to update the firmware. So When I tried it again it said openocd is not a command I tried on both DexterOS and Raspbian. I then installed openocd and got another error:
Runtime Error: embedded:startup.tcl:47: Can't find interface/raspberrypi2-native.cfg in procedure 'script' at file "embedded:startup.tcl", line 47

By the way why isn’t there a readme for the firmware?


#2

Are you sure you’re using DexterOS or are you using Raspbian for robots? If you’re using the command line, you’re using Raspbian for Robots. Either way, you shouldn’t need to install openocd and that may have actually broken something.

This is all outlined in detail here, but the short of it is condensed below.

With Raspbian for Robots you have two options:

  1. The Desktop - You can click on the Software Update icon, update it if you haven’t updated in the last few months, and then select your robot and update the firmware.

  2. Run the install script on the command line, found here. We recommend only doing this on stock Raspbian, not Raspbian for robots.


#6