VNC - Connection Refused by Computer


#1

Hello,

We’ve had the GoPiGo a couple months now, I updated the firmware like a month ago, everything has been working great. My daughter was able to get in via VNC and program scratch, I could get into terminal as well. Today though, I am getting Connection Refused by computer when I attempt to use VNC from the web page on the pi (Launch VNC | Launch Terminal. I can still get into the terminal though. Do you have any suggestions on what to troubleshoot for the VNC? Thanks for any help!

  • Paul

#2

So, I cannot connect via your webpage in chrome - 192.168.2.118:8001 BUT i can get in via VNC Viewer with ip:5901. Do you think this might be a chrome update issue? (tighter security)?


#3

Did you try dex.local?


#4

I haven’t been able to get that working so I just use the ip address.


#5

Hmm. It works for me. Maybe try firefox. Except you’ll have to use the IP address.


#6

@paul.reisinger: do you use WIndows, if so can you install Bonjour from here which should let you use dex.local.

Can you send a screenshot of the Connection Refused screen


#7

I was able to get dex.local to work but I still cant get to VNC anymore. Even the stand alone VNC Viewer (RealVNC) is now getting connection refused. I can get into the terminal from the browser page.


#8

As far as I know you can’t just type :8001
You first need to type dex.local or 192.168.1.118 then click vnc.
Also are you typing 192.168.1.118:1 in the vnc viewer?


#9

When I hover over the VNC logo you can see the link (bottom left of the screenshot) that will get directed to when clicked. This used to work just fine. Im not sure what happened or could of happen to refuse my connection. I would hate to have to reimage my disk.


#10

May have to reimage. Maybe try a different browser. Also try installing real vnc. Then you cannect without a browser.


#11

Hi @paul.reisinger,

Do you have your Ethernet connected between Pi and computer. If so try disconnecting the Ethernet from Pi and the try the VNC on the browser. Try also clearing the cache from the browser it helps at times like this.

-Shoban


#12

This seems to happen to me after a couple VNC connections. I image a new SD, I can vnc into it for like 5-10 times then it stops allowing connections. realVNC I get connection refused and I get an error (Server disconnected: error 1006) or cannot even reach the web interface (when I cick the vnc icon). Doesn’t matter if I am connected via Ethernet or wifi or if I try with dex.local or ip address. I did setup the Browser streaming robot example and I did chmod the home/pi 777 so I can make changes. that’s about it though. Are there some command lines I can run to see if the vnc server is running or get some info on it? what version of vnc server is running?


#13

well, I ran the command vncserver and as you can see set a password and was able to vnc in using vnc viewer. I “think” I am ok now…


#14

@paul.reisinger do you think this was solved by changing the password? When you receive this error above, were you able to ping either the ip address or http://dex.local ?


#15

@paul.reisinger,


I also have seen this behavior when the Raspberry Pi is still booting up.
So the page at dex.local would load, but when I’d get to the VNC page it would give me a Server disconnected : code 1006.

What I did was to wait for some time before I could VNC successfully - this is related to the Raspberry Pi that’s still booting up.


When does this happen to you?
And what OS and browser are you using?


Thank you!


#16

I would get the error when I was direct Ethernet connection or on wifi. It just seemed to stop working. I typically use chrome on windows 10. Honestly I don’t know why it wold stop working. It stopped working on my previous image and then I created a new one and it worked ok for like a day then stopped connecting at all. I could still always et to the dex.local page as well as the terminal. Maybe its a chrome version and websocket support. I’m not to sure.