VNC server frequently disconnect


#1

I get frequently disconnected by the VNC server and I have to login again.
Did someone had the same experience?


#2

Hey Matteo, are you using the Raspbian for Robots image? And are you using the noVNC through the browser, or through a VNC application?


#3

I am using the SD card in the GoBox package with the preloaded image. I did a SW update after wifi install.
I connect through a browser. It happens with Firefox on Ubuntu and also Epiphany and Chromium with a Raspberry


#4

We are experiencing the same issue with our GoBOX. Anyone have a solution for this issue.


#5

Avila, Matteo: how are you both powering your GoPiGo when you’re having frequent disconnects? Are you using batteries, or are you using the power supply? Can you try connecting for some time with the microUSB power supply plugged in; does it make a difference in how frequently the VNC disconnects?


#6
  1. I tried what you suggested last night with the power supply and noVNC did not drop on me when I had the power supply connected only. But I tested it with my Mac not the Windows laptop. I will test Windows tonight and report back.

  2. Can you run the power supply and the battery at the same time ( I have not done this yet but would like to know if i can)? It would suck if i had to power up power down and power back up just to run the code.

  3. on a side note the way you have the pi attached to the motor control bored is weak if you have to be plugging the power supply in and out on regular basis.


#7

Hey avila, this is great news. We know that as the batteries get worn down, the wifi dongle and then the ethernet are some of the first things to go. If you want to untether the Pi, you might need to replace your batteries.

You can run both at the same time: you can connect the batteries and connect the power supply. Be sure to use Rasberry Pi power supply or a 2A power supply. Some folks power it off their laptops, this is a bad idea. You need the 2A power source.

Are you using the GoPiGo1 or GoPiGo2?


#8

Hey John, I have the GOPiGo2. The battery pack ended up being the main issue. Not sure if the batteries drained while we waited for mission 1. But replacing the batteries fixed all the issues we where experiencing. One of the indicators we noticed once we got VNC working was the move forward for 2 seconds acted different every time we ran the code.

Thank you for your help.


#9

Hey Avila, that’s fantastic, great to hear. Yes, when the batteries start to drop, connection becomes an issue. Thanks for letting us know it was solved.

Also, one more helpful piece of advice: while you’re programming and if you need to troubleshoot tricky connections, we recommend connecting the 2A Raspberry Pi Power Supply!