VNC Viewer Question


#1

Alright, I am a bit of a noob so please be patient. I just got the GoPiGo today, got it all assembled and connected it to my computer. All was going well. I followed all of the steps. I thought I got the robot connected and then I shut down and restarted the robot. Now I cannot get it to connect again. I have even disconnected the Raspberry Pi from the rest of the robot, connected via the ethernet cable and exteral power supply (via the mini usb) and NOTHING. I keep getting a “Request timed out” message. Please advise.

Okay…I have a spare Raspberry Pi so I tried using it and got the same timed out message. I think it might be something with the SD card. How do I reimage it (or whatever it is called when you rewrite it…noob remember?)?


#2

You write “I thought I got the robot connected.” Why do you think it was connected? Did you ping the Pi?

A couple of questions before you rewrite it:
How are you connecting? With an ethernet cable?
Do you have an ethernet cable and wifi dongle connected at the same time?
Are you using a PC or Mac to connect?

Thanks! John


#3

John,
I had indeed pinged the Pi. At the time I had had the ethernet cable and wifi dongle connected at the same time. I had tried to ping it again with both connected, as well as with them connected one at a time. I was using a PC (HP laptop) at the time.

Thanks for your help!


#4

I don’t think there’s a problem with your image now though, no need to rewrite over it. There’s some problem with the wifi setup. Maybe a firewall is up on your network?


#5

Hi,

I have exactly the same problem. Ping worked with Ethernet cable. Wifi established first time. All went well. Shutdown. Restart without Ethernet cable. Ping does not work.


#6

So Jawa13, you have a connection over ethernet, is that right? Have you setup the wifi network and are you able to ping google.com on the wifi network from VNC?


#7

Yes. With Ethernet cable, I was able to ping dex.local, dexterindustries.com, google.com etc. No problem with the cable. Without the cable Request timed out.


#8

Refer to http://www.dexterindustries.com/topic/ethernet-lights/#post-69001