VNC won't connect over Ethernet


#1

We recently went through all the setup instructions for the GoBox’s GoPiGo2 but hit a snag when trying to connect over VNC using Ethernet. We were able to successfully ping dex.local and I can connect to it using the dex.local page, but when I click on VNC I get a grey page with a bar across the top that says “Failed to connect to server (code: 1006)” (and “send Ctrl+Alt+Del” button on top right). I’m able to connect, log in and shut down the pi via the Terminal (browser) button on the dex.local page so I know the pi is on and working.

Things I’ve tried:

  1. Restarting the pi
  2. Dexter card switch in off and on position
  3. Turning off my computer (windows 10) firewall
  4. Searching the forum & web

Additional Question:
When connected to the computer, it is unclear from the instructions if you are:

  1. Suppose to have the power switch on or off
  2. Have the battery connected or not
  3. If 1 and/or 2 matters

Thanks!


#2

Hi,
Can you try the steps on this page: http://www.dexterindustries.com/BrickPi/getting-started/using-the-pi/connect-to-your-raspberry-pi-from-a-mac/ and see if RealVNC works. You should use dex.local:1 to connect to the VNC. Can you attach a screenshot of the error that you are getting.

If you are just testing the GoPiGo and are not going to run the motors, then you can power everything with the microUSB on the Raspberry Pi itself, but if you are planning to even run the motors for a few seconds or move the GoPiGo around, then you should definitely connect the batteries.

-Karan


#3

Karan,
Thanks for the quick reply! The instructions are for Mac and I’m using Win 10, but I get the idea. I’ll try downloading the client instead of the web version.

I’ll try to get a screen shot when I test it next, but it’s almost exactly like I described: I see what should be VNC in my web browser but in the top bar instead of asking for a password, it says “Failed to connect to server (code: 1006)”. There’s nothing else on the screen.

Thank you for answering the side question about power. As a follow up, does it matter if I leave the power plugged in with the switch off or should I leave it plugged in because the switch serves the same purpose?

Thank you!


#4

Hi,
Can you try burning the image again to the SD card again (instructions here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/). Something might have broken on the VNC setup on the image.

You can leave turn the power switch on the GoPiGo off if you are powering it from the microUSB, but be a bit cautious so as not to use the motors. It is usually better to just leave the switch on, the GoPiGo takes the power from the USB and the motors are powered from the battery in case they are switched on.

-karan


#5

Good news!

Using realVNC viewer from https://www.realvnc.com/download/viewer/ over dex.local:1 worked perfectly! I’m not sure why the browser version over 8001 doesn’t connect, but at least this works and will let us continue.

One additional question that has come up… I have a 4k screen and the desktop is SUPER small (see screen shot) and is almost too small to use. Is there a way to increase the resolution so it’s bigger? I tried going into Display Settings but it says “Unable to get Monitor Information!”.


#6

Hi,
Glad to hear that it worked for you. Did you burn a new image to the SD card or is the same old image, and if so any idea why it was not working with RealVNC the first time. We’ll have a look at implementation of VNC in Browser and try to find out the problem with it.

To change the screen resolution, there is a setting called hdmi_mode. You’ll have to try out the different values and see what works best for you. There is a guide here on how to change it: https://www.raspberrypi.org/documentation/configuration/config-txt.md.

-Karan


#7

I didn’t burn a new image and retried using the “web” version and it still doesn’t work. It only seems to work with the RealVNC client.

I’ll try the screen resolution settings and post my findings in case anybody else needs them.


#8

Were you able to at least login using the web browser at http://dex.local ? Does the terminal work?