Where is the username and password?

Yo.

https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

Followed the unstructions on the page above to install Raspbian for Robots, went to the Sourceforge site, downloaded the Raspbian for Robots image, burned it onto an SD card.

Boot the device

It asks for a username and password for

GoPiGo login:

No info on the page linked above

searched forums

tried

pi + robots1234

nope

tried

pi + raspberry

nope

  1. please tell me the username and password
  2. please fix the page above

point a browser to the Raspberry Pi IP xxx.xxx.xxx.xxx and you will see

Click on either the VNC for desktop or Terminal Icon for a command shell, then use the robots1234 password.

(You cannot log into the boot screen that you were looking at.)

OR continuing on the instructions page you used:

SSH in from another computer to the RPi:

Ah, good suggestions. However, my device keeps returning IP address 10.10.10.10 and that IP is unreachable.

I have tried plugging straight in to our local network, everything, I keep getting 10.10.10.10 IP

Why did they remove the desktop environment and then make it so you can only SSH or VNC in? This is all very odd. The OS went from one that was great for teaching to one which is impossible to trouble-shoot.

Frustrating.

Tim

I can’t speak for DI, but it is an OS for mobile robots, which makes an hdmi connected monitor somewhat difficult to use and Remote Desktop quite convenient by comparison.

This is the way I bring up my Raspbian For Robots:
*** Download Raspian For Robots
https://sourceforge.net/projects/dexterindustriesraspbianflavor/files/latest/download

*** Flash SD card with Etcher
Select the Raspian For Robots zip file
Select the 16GB SD Card
Flash

=== Mount the card to allow headless configuration

  • Pull card out, reinsert for next steps
    (The Boot partition will get auto mounted)

=== Enable SSH

  • create file called “ssh” (or ssh.txt) in the Boot partition

=== Setup WiFi Headless

  • create the file wpa_supplicant.conf in the Boot partition
    (note: quote chars must be straight up/down, traditional, not slanted/matched Unicode chars
country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="your_WiFi_SSID"           
    psk="your_WiFi_password"
    key_mgmt=WPA-PSK
}

=== disable ipv6 (I need this - you may not)

Browse the disk (boot)
Rt Click on System Volume Information->Open Terminal Here
cd …

cp /boot/cmdline.txt /boot/cmdline.txt.bak
nano cmdline.txt
add to end of line/file:
ipv6.disable=1
save, exit editor

  • eject disk

==== Raspbian First Boot
-insert micro SD card
-power on

  • on mac: arp -a to find IP given to system by router

=== First Login
ssh pi@10.0.0.XX

=== If see SSH HOST KEY verification failed
on mac: ssh-keygen -R 10.0.0.XX

Login: username: pi password: robots1234

Next I change the password and the tightvnc password and the machine name and reboot

Next I go to my router and reserve the DHCP address the Pi was given so that it will be the same every time from now till eternity.

@bostelle
You seem to be running DexterOS and not Raspbian for Robots.

Only DexterOS would use IP address 10.10.10.10
You need Raspbian for Robots for your needs.
Get it here:
https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

2 Likes

I tried the password provided here but for my gopigo it wont accept those credentials. I havent done any config and even password change yet. I am just testing it and tried using the root pwd but it fails… Any suggestion

Hello @madapaka_sana
the ‘robots1234’ password will only work on Rapsbian for Robots. If you are using DexterOS, then you don’t get access to the system. You need to connect to the robot via its wifi access point, then control it via your browser.

Hope this helps.

1 Like