WiFi adapter field is blank in Wifi Setup[SOLVED]


#1

Hi, I am new to Dexter and the forums. Just bought my first GoPiGo kit and eager to get it running.

I have a realtek usb wifi adapter for my raspberry pi 2 and am trying to setup wireless. I have the latest Raspbian for Robots operating system installed. The adapter field is blank in wpa_gui application (wireless setup). When I plug-in the wifi adapter and do ‘lsusb’ I get the following:
Bus 001 Device 004 —Realtek Semiconductor Corp RTL8188CUS 802.11n WLAN Adapter

I even went in and in /etc/network/interfaces added the following lines and rebooted:

auto lo
auto wlan0
face wlan0 inet manual

(the “auto lo” line existed before, should I delete it? what does it do?) I also checked that I have the latest “firmware-realtek” package installed when I did sudo apt-get update

Anything I am missing? Thanks.


#2

@contactvega: can you post the output of dmesg and ifconfig after boot.


#3

Have you tried setting up WiFi graphically? If your using raspbian for robots there should be a WiFi setup icon on the desktop. Raspbian also has a GUI WiFi setup.


#4

Attaching the output of ifconfig and dmesg in text files. Thanks.

ifconfig.txt (1.3 KB)


#5

looks like I can only attach 1 file in a message, hence attaching this in a different message. Thanks.

dmesg.txt (21.8 KB)


#6

@contactvega,
The Pi able to detect and load the wifi adapter that you have connected. Can you send a screenshot of what the WiFi setup utility on the Desktop shows.


#7


#8

attaching 2 screenshots…


#9


#10

Hi @contactvega,

Can you share with us the name of the image and version that you have on the SD card and also can you check if you are able to see any wifi device name called dex showing up on your computer wifi device list, just to confirm that you are not using the CINCH image.

-Shoban


#11

This is the version information I get when clicking on the version icon on my installed system. Is this what you are looking for?


#12

That image is a little old.


#13

Hi @contactvega,

Can you try our latest image of Raspbian for Robots by downloading it from here and you can install it following the instructions given here . Please tell us if you continue to see the issue in this image.

-Shoban


#14

I re-installed the image and that solved the problem. This time the WiFi adapter was attached during the first boot. That’s the only difference I can see. The image that @Shoban pointed me to is the same as the one I already had. Thanks.


#15

This topic was automatically closed after 24 hours. New replies are no longer allowed.