Wifi issue with the Pi


#1

My pi (using dexter SD card) is not connecting to my home wifi. I have been trying for almost 6 hours plus but still have not figured out the solution for this. I have tried assigning static IP as there was a post saying that as a solution but that did not work for me. The issue I see is the pi is not getting an IP address from the DHCP. I have confirmed that I am using DHCP from network preference, so that is not an issue. In my router, I see the Mac address of the pi, but its getting assigned a 0.0.0.0 as IP address. Please see the attached screen shot. Thanks for your help.


#2

If your RPi is truly associated with your D-link wifi router, then giving it a static IP (such as 192.168.0.200) should be enough to allow the RPi to ping the router and other systems in your local network (and for them to ping the RPi).

If the D-link display in your image was a routing table then I’d think your router was trying to route to the Internet by way of the 0.0.0.0 entry. 0.0.0.0 makes no sense as an assigned IP address. I suggest you look through the D-link configuration, in case it’s misconfigured somehow.


#3

The IP address that can be seen in the screenshot, 169.254.37.31, is that the one you assigned as a static IP?
That type of address, starting with 169, is only valid for an Ethernet connection, and not a Wifi one. It should be starting with 192.168.0 for a valid wifi connection on your D-Link


#4

You might want to try updating the OS and firmware so start with a wired connection, do the updates and then attempt to connect with wi-fi. I had nothing but trouble until I did this and it fixed it. My Pi has been up for days with a solid connection while before… it would lose the wi-fi every few minutes and I was rebooting constantly.


#5

Thank you for your response.
I have tried to connect the pi to internet using wired ethernet but still no success.
So I can’t really update the firmware.
When I do a ifconfig it showing lots of dropped packets. Please see the attached image.
Cable or connection is not the issue as I can connect my Macbook.
So currently I cannot get to internet either using wifi or ethernet in my Pi.
Can this be a hardware issue? Or issue with the provided DI software?


#6

Which Pi are you using and did you buy the SD card from us or download it from the site. Also which wifi adapter are you using and is there anything special with you wifi network or is it just a wifi router which connects to the internet. Can you run the troubleshooting script and upload the log on the forums by following the guide here: https://www.youtube.com/watch?v=ZMadpIEYq5o .

-Karan


#7

When you did that Snapshot, what was the setup? I’m not seeing a wlan0 in it, so I’m assuming you had just an ethernet cable connected to your MAC? Is that the case?

I’m re-reading your posts, and it’s not clear to me if you tried connecting the Pi via ethernet cable directly to your D-Link router. Also did you remove the static IP assignation you first did?
I’m only trying to get a clear image of where you stand now.

Cleo


#8

I am using the pi that comes with GoPiGo starter kit. I bought my pi 2 weeks ago so it should be the latest one(GoPiGo2?). Nothing special about my wifi router, Xfinity > Arris Modem > D-Link Wifi Router. I have multiple device connected without any issue. What surprising & worrying me that even hard wiring the pi into the modem using ethernet cable is not making the pi talking to internet. I have ran the troubleshot and please find the log file. Also attached a screen shot of ifconfif.


#9

I’m sorry, this must be getting frustrating.
Could you, please, post the content of your config.txt file found in /boot on the pi? (in other words /boot/config.txt )

Thanks


#10

Please see attached


#11

My apologies, I meant /boot/cmdline.txt
But config.txt is also interesting to look at. It doesn’t seem to match mine. I’m looking into the differences to see if they would be significant.
Which version of the Raspbian for Robots card do you have? The file on the desktop called Version would have the relevant information.

Cleo


#12

cmdline file attached.

Version:
V 6.6

This version of Raspbian was modified by Dexter Industries on the Wheezy Raspbian Build.
This version was updated on 2015.11.04


#13

Thank you for your patience

Can you remove ip=169.254.215.82 from the end of the cmdline.txt file, reboot, and then connect your Pi via Ethernet directly to your router?

The cmdline.txt file is a bit touchy. You’ve edited successfully, so you know how it works.

The static IP works only when connecting directly to a laptop, otherwise it interferes with DHCP


#14

I had added ip=169.254.215.82 it as per instructions from this video: https://www.youtube.com/watch?v=q7mdXGxBuDI

Now I have removed it, nothing changed.
My pi does not connect to internet.
This was supposed to be a weekend project with my son, now after 3 weeks and 20+ hours of work I did not go anywhere.
Absolutely frustrating.

Is there a way I can load the SD card with latest version of raspberry pi, DI software and firmware from my Mac?
Effectively, I am hoping to download the contents into my Mac, delete the current contents in my SD card and load those with the downloaded content?

Thanks!


#15

You can get the latest image for the SD card by following the intructions here:
http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

It’s not just a question of transferring the files onto the SD card. It’s an image that needs to be ‘burned’ onto the card, so there’s a process to go through, but it can all be done from the Mac.

Something just dawned on me, is it possible that, by some remote chance, your D-Link is set to only accept a specific set of MAC addresses? It’s recognized as the best level of security (with wpa-2) and more and more home owners are now set up that way. I don’t know if it’s your situation but it would explain why the Pi isn’t getting an IP assigned by DHCP.

When you removed the static IP address from the Pi, and connected it directly to your router, what information did you get? I understand it still wasn’t connecting, but what did ifconfig show? And what did the router show?

Cleo


#16

Oh and another option that may interest you:
https://sourceforge.net/projects/dexterindustriesraspbianflavor/files/Cinch/
This is called Cinch. It’s exactly the same Raspbian for Robots, except it behaves as an Access Point. In other words, it’s a wifi emitter, and your laptop (or desktop) connects to it instead of connecting to the internet. That way, you would be able to control the GoPiGo wirelessly. The main feature of Cinch is that it’s completely independent of your home wifi. The downside is that you can’t be on the internet at the same time as you’re controlling the GoPiGo.