Will a PiCam v1.3 work on a GoPiGo kit with a Pi3?

dexteros
picamera
#1

Ref: Related discussion at:

I tried the same tests, including a new, verified by Etcher, flash of Dexter 2.2.2, and get a slew of error messages ending in “Camera not detected”

Any attempt to use the camera programmatically results in the same error. I tried the tests in the previous post - the camera is “enabled” but none of the functional tests worked.

Any available guidance would be gratefully appreciated.

Jim “JR”

0 Likes

#2

I received that once. Solution for me was to reseat the cable into the connectors at both ends, all the way in and blue stripe on the proper side. A bit of a pain, because I had to remove the top plate and disassemble/reassemble the 40 pin connector of the GoPiGo3.

0 Likes

#3

Hi @jimrh,

Just strictly thinking of your question: I had tested a Pi Camera v1.3 on DexterOS and it worked for me. And yes, I have to concur cyclicalobsessive’s comment in that you have to check if the cable is plugged in correctly.

Thank you!

0 Likes

#4

Been there, done that, bought the t-shirt. ( :wink::wink::wink: )

That was one of the first things I tried. I also looked at the tiny connector right above the camera itself to make sure it was plugged in correctly. (Though I might just un-plug it to re-seat it and make sure there’s a solid connection.)

I have another Pi-3 laying around somewhere and I might just pull it out of storage and give it a try.

In any event, you’ve told me what I needed to know - version is not an issue.

Let me play and we’ll see what happens.

Thanks!

Jim “JR”

0 Likes

#5

Update:
Found a Pi-2B, installed the camera, launched Raspbian (stretch) Sudo’d to root, did an apt-get update, upgrade, and dist-upgrade. Note that everything I’m doing I am doing as root. (to avoid any potential permissions issues)

Went into RaspiConfig as the default user, turned on the camera, saved out and rebooted.

Tried the "raspistill -o test.jpg test as root. No joy.

Note that the first time I run that, a red LED lights up on the camera for a few seconds. Subsequent tries do NOT light the LED until rebooted.

I get the following error:

root@raspberrypi:~# raspistill -o test.jpg
mmal: Cannot read camera info, keeping the defaults for OV5647
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly

root@raspberrypi:~# 

This is on a different board with a different O/S (Raspbian).
I’ve checked cables carefully.
I have carefully visually inspected the cable itself for kinks, loops, or breaks in the flex-traces.

The cable is installed thusly:

  • Cable is plugged into the Raspberry Pi with the blue spacing/stiffening shim facing toward the audio jack. (facing away from the HDMI port.
  • Cable is plugged into the camera so that the blue stiffener is facing AWAY from the PCB.
0 Likes

#6

Hi @jimrh,

You know, I’ve had this problem once too, but with the 2nd generation of the Pi Camera - after some time I realized it’s burned and had to replace it.

Did you also try seeing what the output of vcgencmd get_camera is?

Thank you!

0 Likes

#7

Not yet. I’m rapidly coming to the conclusion that either the camera or the cable is toast.

Jim “JR”

0 Likes

#8

I purchased 15 of the Raspberry Pi V2.1 cameras. Two of these were dead on arrival and had to be replaced. The vendor was good to replace them.

As I mounted the camera on a servo, there were some loose cables but these were easily fixed and likely caused by failure to seat the cable properly and push in the retaining clip.

Both bad camera and loose cable show the same error you reported above.

0 Likes

#9

Wow, 2 bad cameras out of a batch of 15 is a big number. Just saying.

0 Likes

#10

Turned out my problem was a bad flex-cable. I had to cut off the contacts at one end, strip it back about 5mm, and then re-insert it to get my camera working.

Jim “JR”

1 Like

#11

I had similar and fixed by using pencil eraser on the cable contacts, then cleaning the eraser schmutz off as well.

1 Like

#12

In my case the foil contacts at the end had begun to curl and some had broken at the edge where the contacts go under the insulating coating.

If the contacts on a flex cable begin to lift, sometimes you can get them to re-adhere by running a tiny soldering iron tip along them, the heat re-adheres the trace to the substrate. I tried that and several simply fell off having cracked at the interface.

I ended up cutting the exposed end off – reducing the length of the reinforced area by one half – and then using a fine emery cloth to carefully  abrade away the white insulation far enough back to get good contact again.

Scary, but sometimes you don’t have much choice.

Jim “JR”

1 Like