Windows IoT GrovePi+ not working


#1

Hello Everyone,

I am currently experiencing problems running Windows IoT with raspberry pi3 and GrovePi+.
I have used the tutorial provided on this website but I am not able to make my led blinking :frowning:
I have tried other samples available but nothing worked.

The only thing I have been able to achieve is writing the grovepi firmware version in the output (1.2.2) with:

System.Diagnostics.Debug.WriteLine("Firmware : " + DeviceFactory.Build.GrovePi().GetFirmwareVersion());

Anyone already have this problem when starting with GroPi+ ?

Thnx,
Cedric


#2

Ok, to check if I was doing something wrong, I have installed “Raspian for robots” and followed the tutorial here:
https://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/

I have tried the “grove_led_blink.py” script but the led is not blinking. So it seems it is not related to Windows IoT.


#3

Oh no … Found the problem … there is no LED in my starter pack, I was using the light sensor …
Seriously ! Why are you wirting a Windows IoT getting started with a led and not providing it …


#4

Hi Cedric,

Tell us:

  1. Did you get the GrovePi Starter Kit or the GrovePi module alone?

  2. If you can answer the 1st question with a yes and if you don’t have the LEDs in your kit, then from where have you got the GrovePi Starter Kit? Please name the distributor.


Here’s my GrovePi Starter Kit on the table.
It should look like this.


Thank you!


#5

Hello @RobertLucian, Thank you for your answer.
I don’t have this starter pack. I have the windows iot starter pack from seeedstudio:

And there is no LED inside, even on the website description. And the light sensor was so close to a led module that I didn’t even read the name on it.

Then trying your tutorial I spent nearly 4 hours wondering why it was not working properly even though my code was executing properly. This is only when I tried on “Raspian for robots” with the RGB led bar that I discovered the grovepi was working, and then discovered it was a light sensor :slight_smile: … ah ah 4 hours trying to light my light sensor :slight_smile: … seeedstudio should add this module in the package or dexter have to change there tutorial.

And now I have a problem with the Grove NFC Tag, if I understand correctly what I have read on seeedstudio. They provide a sensor working in UART and the sample provided with grovepi is in I2C on the raspberry … What the F…? Well it is probably not the place for this question so I will try to ask on seeedstudio community.


#6

Ooooh this sure is confusing. Unfortunately we have no say over the Seeed Iot starter kit, our tutorials are meant for our kits. Really sorry you had to go through that painful :confounded:experience.