Won't ping or connect to setup


#1

Hello! My (5 yr old) son and I are working on the GoBox and we are super new to all of this, so please forgive our state of “noob.”

I cannot get past the ping step to setup the wifi, or to even connect via ethernet to any of our computers. I even managed to kill our internet access while trying. The good news is we’re back online, at least.

What can we do? I’ve tried two different computers with two different operating systems.

I was able to get into the robot’s interface 1 time using dex.local in my browser. After that it failed and has not connected again. Each time I’ve tried, the ethernet lights DO light up, both of them. I am using a wall plug for power. The motor and the battery pack are disconnected. I’ve tested with the wifi dongle plugged in and with it removed.

I’ve checked for updates, I’ve even downloaded a new image of the Rasberry OS from your forum to try a fresh start on the SD card.

I’ve tried disabling my firewalls (which I’ve since re-enabled).

I do have Bonjour setup, I even installed iTunes in case it would help. My computer of choice is Windows 7 pc. The 2nd choice is an older Vista PC.

Help, please!


#2

Sorry to hear about the frustrations. Thanks for all of the information; I’m sorry if I start asking redundant questions in advance.

First, let’s stick with Windows 7. We seem to see some customers having trouble with connecting over ethernet, and unable to connect to dex.local. Let’s first try to get you connected to dex.local with an ethernet cable.

Just to double check, with your pc, if you go to your Network and Sharing Center, and open the Local Area Connection. Click on “Properties” and then click on “Internet Protocol Version 4” do you have both “Obtain an IP address automatically.” and “Obtain DNS server address automatically” selected, or do you have set IP address numbers?


#3

I have both setup to obtain automatically.


#4

Ok, so with the Raspberry Pi connected to the Win7 computer over ethernet, the lights are on, and the ethernet lights are blinking. Firewalls are off.

First, I would try to shut the wifi off on the Win7 machine. Sometimes this seems to confuse bonjour. If you can try to shut the wifi off, then go back to the command prompt and type “ping dex.local” ; it may take 5 minutes for your PC to find dex.local.

Second, If that doesn’t work, one thing we’ve seen work for folks is to assign a static IP address. I just wrote a quick tutorial on how to do this on youtube here: https://www.youtube.com/watch?v=P4yg8RYtTJs

If the first doesn’t work, can you try the second option, assigning a static IP address?


#5

Thank you for your continuing assistance! Step 1 did not work, so I tried the second. I assigned the static ip address by following the video. After a few failed tries, I had to change the ip by 2 digits, instead of just one. Then it pings!

Only the static ip pings, but not the dex.local, that still fails.

Then I connected to VNC, and was able to get to the password screen, again using the new ip address.

After entering the password, the screen refreshed and I saw a grey box where the desktop should be. I tried to login with two browsers, with the same results. I also tried with wifi on and off.

I’ll attach a screen shot to show you.


#6

Hey dreamydragon, thanks for the clarification, and thanks for the update, that’s great to hear! Let me think a little more on this, this is a first for me. Two more questions:

1). Are you able to login through terminal in the browser (selecting th eother option on your browser instead of vnc)?
2). Does a reboot help? Sometimes cycling the power could help?