Yeah, this isn't working


#1

I need some help. I have no networking experience. I bought the BrickPi and the Dexter Industries SD card. I went through the instructions many times, but was not able to get the Brick to connect to my computer using an Ethernet Cable. The putty program always timed out with no connection. I am able to connect to the BrickPi with my TV and a mouse. I tried to run the Python test motor program and got the error message #No module named BrickPi What do I do now? Sadly, I don’t even know how to reformat the SD card. If I can’t connect to the internet how can I run the updated file install that keeps getting mentioned on the forum? Dexter promised me a card that would work, but apparently it does not. Do I wipe out the card and start from scratch? How do you do that? Ask Dexter to send me a new card? I have been reading the forum and I have no idea what people are talking about. I really thought that this would be an easy to use item. From what I have been reading, it seems that you need some advanced skill to set this up. Am I in way over my head? I am a simple physics teacher who had some Legos motors and sensors laying around. I wanted find a way to teach the kids coding (I have some Python experience) but this has turned out to be a giant fail. Does anyone have any advice?


#2

oakyjoey,
Sorry to hear about these troubles. It’s not time to give up yet though, or to reformat your SD card. We developed the ethernet method of connecting to try to make it super easy, but it’s not necessary to get going.

First question: do you have a way to hook up the RPi to the internet? Can you plug it directly, via Ethernet, into your home router?

Next question: when you hookup your RPi to your computer, and you power up the RPi, do all of the lights next to the ethernet port light up? Do they form any pattern or do they just seem to be sending and receiving info.

I would really like to work through this with you, so please bear with me on this. If we can connect you to the internet, any way, we have a chance.

Best,

John


#3

I can connect my RPi directly to the router. I did not try that since I was trying to use my laptop as a monitor.

I just plugged the RPi directly into the ethernet switch in my classroom. From top to bottom this is what the lights did:

ACT - flashed at a high frequency and then slowed to a stop.
Power - stayed on. (BTW, I checked the voltage using Pin 2 and Pin 6. My voltage is 4.8 Volts. The mini USB charger is rated at 850 mA.)
FDX - The green light stayed on.
LND - Constant flashing at about the same frequency as the ethernet switch lights.
100 - The yellow light stayed on.

Any help would be appreciated.


#4

Also, when I look at the IP address that I am supposed to pick. Is that the wireless LAN or the ethernest LAN?

Also, I have a question about your directions:

  1. With the power off, remove the SD card from the Raspberry Pi. Open this in your computer, and open the file “cmdline.txt”.
  2. Save a copy of this file as “cmdline.bkp”.
    You’ll need to choose an IP address for your Raspberry Pi.
  3. First connect the Raspberry Pi with the ethernet cord.
  4. Open the command prompt. Type “ipconfig”. You will see a list of IP addresses and you should see “Ethernet Adapter Local Area Connection”. You will see your computer’s LAN IP number.
    We recommend you use the same address as your computer (laptop or desktop) and add 1 to the last digit. EG: your laptop is 169.253.181.60, you should choose an IP address for your RPi of 169.253.181.61.
    add ip={your IP number} With our example IP, the whole text file looks like:dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait ip=169.253.181.61
    There should be NO returns or new lines in this file. Save it.
  5. Plug one end of your ethernet cable into your Raspberry Pi, and the other into your computer ethernet card.
  6. Power the Raspberry Pi up.

I left step six blank because it makes no sense to me to not put the disk back into the Raspberry Pi, but you don’t tell me to. Since I don’t know what is going on, I don’t what to do.

Thanks!


#5

I need to add that when the Dexter Insdustries formatted boot card is inserted, the only light that comes on is the Power. The student that I am supposed to be helping, formatted his own SD card using your instructions. When using the formatted card, we get all the flashing lights, but we cannot connect to the internet and the python motor test file gets the errors. We can connect to a monitor and see the start screen. I have tried over and over. I am not sure what to do.


#6

Next, I set up the RPi again as using my classroom projector as the monitor. I connected a separate keyboard and mouse. I can get on the internet using Midori. I went to the LXterminal and did the
sudo apt-get update
sudo apt-get upgrade

Next I tried Python. I keep getting an error message on the motor test. It says "No module named Brick Pi.:

What do I do next to get be able to use python?

Thanks!


#7

Regarding Networking: Aha, in a classroom! Did not see that. Is there any firewall or other networking protocol that might be preventing things from running on the school server? That could be part of what’s tricky about connecting. Maybe a school IT person can look at it and see if there’s some software running that’s limiting what can get on the internet?

Regarding the Python Fail: I was curious how you got the python examples over to the RPi without internet connection. Did you move them over to the RPi on a USB Memory Stick? If you have that package in a directory, we should be able to resolve the problem in one of two ways:

  1. The elegant way is to run the commands under the Installation section of this page http://www.dexterindustries.com/BrickPi/program-it/python/ ; open terminal, change directory to where you unzipped the BrickPi_Python files, and run
    apt-get install python-setuptools
    and then
    sudo python setup.py install
    (If you are not connected to the internet, the apt-get command will fail, so skip it and try the second command).
  2. If that doesn’t make sense, copy the file “BrickPi.py” into whichever directory the BrickPi python program you’re trying to run is located (IE, copy it into either “Sensor Examples” or / and “Project Examples” folder.

After you do one of these two steps, do you have better success compiling one of the Sensor Example programs?


#8

Regarding IP Number Picking: You’re looking for the ethernet LAN number. If you connect the RPi up to your computer over the ethernet, you should be using the ethernet IP number.

Regarding Step 6: You’re right, we should have been more clear. After you modify the cmdline file on the SD card, take it out of your computer, put it into the Raspberry Pi. Then turn the power on. I have just added a step for folks that might be confused by this on the instructions. Thank you.


#9

SOLVED: you need to be in the GitHub repository clone folder before running the two commands! I need sudo both, anyway.

Hi,
I am using your image but your instructions do not work anyway. First of all, if I do apt-get install python-setuptools without sudo I get

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root

… so I sudo that command. And then, if I do sudo python setup.py install, it fails as it can’t find setup.py, that sounds reasonable to me, as there’s no setup.py in my current folder.

What did you miss?

G.


#10

G, thanks for pointing this out. Absolutely sloppy on our part, I appreciate you noting it and sharing it. I’ve just updated the web page, and the Github repo. Thank you sir!


#11

Okay, a nice engineer from Google came over to our school to help us out (YEAH GOOGLE!). We had an extensive trouble shooting session.

First we checked the software. We moved the needed files in to the example folder. This got rid of the ‘no brickpi module’ error, but then we had a new error with ‘no serial’ module. He fixed that and so finally we had no software errors. Unfortunately, the motor still did not run.

Next, we started to check the hardware. We determined was that the motor connectors are getting logic voltage but not getting motor driving voltage. We did this by putting a NXT cable into MotorA port and checking the wire voltages as the program ran. The engineer says that it is the Brick Pi. Any suggestiongs?


#12

How are you powering the Pi when you get no power on the MotorA port? And which example are you using at this point?


#13

I am using both the mini usb and a fresh 9V, hot off the charger. I am using the motor test example. Reading the code, the motor should run forward for a bit, pause, and then run backwards, etc. The run module in Python shows that the motor is running. I am familiar with python because I had to use Visual Python for several physics classes. Unfortunately, we were only doing visual modeling and no physical interfaces.


#14

Ok, that indeed might be a hardware failure on the BrickPi. Do any of the sensor modules work?


#15

I do not know. I took the whole thing apart so that I could send the Brick Pi back to you. I know that this is a KickStarter thing and, in retrospect, I should have waited to purchase one of these. I am asking if you guys would troubleshoot it for me just so I know what the problem was. I bought the RPi separately and I still hope to do something with it with the students. For now, it is back to RobotC and Vex. Do you have a returns address?

Thanks,

Oakyjoey


#16

That’s fine, we will foot the bill for the return and replacement. I will send you a direct e-mail.