Zero programmer options available under Programmer tab


#1

Hi team,

I have followed the instructions here:

http://www.dexterindustries.com/Arduberry/getting-started/
my Raspberry Pi failed to restart and I had to manually restart it. Unfortunately there are zero programmer options under the Programmer tab. I am unable to perform the “select Programmer” step as there are zero programmer options available. I have tried rebooting several times without success.


#2

Hi @swhobbs2000,

This issue occurs usually because of bad install of the script.
Can you clarify if you have cloned the ArduBerry repository to Desktop. Are you running the install.sh script from /home/pi/Desktop/ArduBerry/script/.

If you haven’t then remove the existing ArduBerry folder and clone it again to Desktop and run the install script following the instructions given here.

It looks like you are using an image other than our Raspbian for Robots. Can you tell us which image you are using and is there any specific reason for using it.

-Shoban


#3

Hi Shoban,
Thank you for your suggestion. I removed the previous installation and re-cloned into Desktop however I still receive exactly the same error. The install has still failed.
I was unable to find anywhere in the instructions that there was a requirement to install in the Desktop (step 3 simply states “go to an appropriate location”).
I also could find no reference in the instructions that Raspbian for Robots was needed. I am using an install for Noobs on an 8 Gb SD card as that is all I have been able to source for my Raspberry Pi. I don’t have internet connectivity to download or try to install Raspbian for Robots.Steven


#4

Hi @swhobbs2000,

The problem you face seems to be because of not being, able to install the script, so it would be apt to continue the discussion here.

-Shoban


#5