Blink LED missing di_i2c from

I am using a raspbian image. The instruction book says this:
git clone
2) run GrovePi/Script/
(did all of this with chmod to executable)
3) reboot

when I go to
then do
sudo python

I get this error message
pi@melzpi:~/GrovePi/Software/Python $ sudo python
Traceback (most recent call last):
File “”, line 37, in
from grovepi import *
File “/home/pi/GrovePi/Software/Python/”, line 54, in
import di_i2c
ImportError: No module named di_i2c

What do I do/do I need di_i2c?

I also tried the robots image, but that doesn’t even launch to the desktop. Instead the terminal is saying GoPiGo login. I tried pi, robots1234 and still don’t get anywhere. No X windows

Sorry! Yes solved with
bash ./

and also did
curl -kL | bash

1 Like

Great that you figured out the “secret step”

For completeness, the reason you could not login to “the robots image” is that you downloaded
a version of DexterOS, which creates an access point and only allows login via a web browser session.

If you ever do want to try “the robots image” that will give you ssh, remote desktop, X, and full Stretch or Buster experience with some DI vendor added benefit - see: