Boot error fsck failed give root password for maintenance


#1

Hi, I got my new Brickpi+ set and I can´t boot because I get the error that fsck failed and the root file system is in read only mode.

I tried it several times with the original sent micro SD-card and the image from 2015.11.09 and after it didn´t work I dowloaded the image from 2016.01.09 but same error.

The errors I get are different most time the last message on the screen is that the fsck failed and the root file system is in read only mode and the request that I have to give the root password for maintenance or press control+D. But no password works, not raspberry or robots1234 and I can only restart with cotrol+D or to unplug the power cable.

Some times I get the user login and after I loged in with pi and robots1234 I´m in the system but everything is in read only mode, so I can´t do anything. I tried it with sudo su and robots1234 but same problem, file system ist still in read only mode.

By booting I can read serveral errors with “segmentaion fault” too.

I have no other free micro SD-card to test because the only ones are 32 and 63GB big and in use in my mobile phones.

I installed the image on my windows 10 PC with diskimager as in your documentation explained.

So I can´t fix the error, because fsck need write access and the system is in read only mode and now I need your help :frowning:

Cheers,
Michael


#2

Hi Michael, I’m going to try to download and install both the rar and zip file, using my pc, just to make sure this isn’t a problem with the image file I put up. It’s possible it’s corrupted, good for me to do a double / triple check on that.

In the meantime, if you’re around, two questions:

Which compressed file did you use, rar or zip?
Did you check the md5 checksum (if your using a PC)?


#3

I just tested this with a PC: I downloaded both the rar and zip files in sourceforge (the 2016.01.05 version). Unzipped with winrar, and then burned them to a 4GB sd card (sanDisk for what it’s worth, probably the same brand you have if you bought ours). I checked the checksum using Win32 Disk Imager and verified that it matched the one in the text file. I burned both to SD cards, and connected them to my ethernet network and I was able to ping dex.local almost immediately.

One other option, if Sourceforge is giving you trouble, is to try to download from our google server. We have these two files mirrored here:

(RAR) - https://drive.google.com/open?id=0B0WChwP4CnLBTlBPamQ0QU83TEU
(ZIP) - https://drive.google.com/open?id=0B0WChwP4CnLBczVNMEdnekQ4WWM

Just as another avenue. Two years ago when we first started offering zipped images like this, we had a customer that could only download from sourceforge, Google wouldn’t work for him. Not sure why it solved the problem, but it might be worth a shot.


#4

Hi John, I have checked the MD5 checksum, it waas the same as on your page.

I have only downloaded the ZIP file from Sourceforge and from Google too (both two times one with the browser and one with jdownloader) and installed it on your delivered mSD Card (after the original installation didn´t work) and installed it with Win32diskimager under Windows10.
After copying the image to the mSD card, the file system on it is FAT (I tested to foramt it before with FAT32 and EXT3, but it seems that Win32diskimager is formatting it new into FAT).

I have tested to install Raspbian (wheezy and jessie) from from the official RaspPi side and one time I had the chance to see the Dekstop and made some changes but it worked very slow and after restart I got, after the regular start routine information, a blank screen or errors like “kernel panik…” or cannot find files and the once above.

Last night (it´s now a midnight shift for me) I found the root password, logged in and tested to start FSCK but it never works, because the system tells me that it can´t find files and also with raspi-config I get error with the file system which I can´t expand or make other changes because /dev/root will not exist.

I can check the RAR files tonight and give you a feedback. What I can also test is with another Raspi modell B rev2 from me to use the mSD card with an adapter and your image. But for this I must open the brickpi case and I don´t know if a Pi B rev 2 will work with your image?!


#5

Hi John, I have tested the mSD card in an older Raspi B rev 2 and it works. :slight_smile:
I have connected the WLAN dongle and BrickPi and everything looks fine.

Now we will start tests with the Lego hardware and the BrickPi contacts.

What´s with the damaged Raspi from your BrickPi+ starter kit, how will I get a new one?


#6

Hey Michael, I’m really glad to hear you got this up and running!

I’m not sure what’s up with the damaged Raspi, we will take it up with Newark, who we buy the from directly. We stand behind our products and we’ll of course replace the hardware, but it’s disappointing to see the Pi foundation shipping us damaged goods like this. Hardware can be hard to handle though; we make mistakes on the parts we manufacture as well.

If you want to arrange a replacement or refund, please contact us at http://dexterindustries.com/contact
and be sure to include a link to this forum post, and information about where you got the Starter Kit from. We’ll make it right.