Brick Pi Motor problems


#1

Hi, I have recently purchased a Brick Pi and have had no end of troubles with it, but, I have worked solidly on it, fault finding and looking into it for several weeks and starting to see some signs of improvement, I.E I have had success in getting one of the examples to work (LED Test.py) but have had problems getting a response from the Motors and have tried some of the example code (LEGO - Motor Test.py).

I think my Brick Pi is broken and would like some assistance on how to replace it please?

I have done the following

  1. Used your DI image on my SD Card (2014.07.30_Dexter_Industries_wheezy)
  2. I have updated my software as Super User using the sudo apt-get install update/ upgrade commands
  3. I have reinstalled the software for the BrickPi using install.sh again using chmod +x and the sudo command
  4. I have used the GPIO on other wiring projects with a breadboard so I know it is not the GPIO that is at fault
    5)The LED’s do work as I have tried LED Test.py which works but Lego - Motor Test.Py doesn’t work
  5. Checked the motors in all Motor ports on Brick Pi to see if they work

I heard somewhere that not being in the correct directory when running the test could be the cause of the problem, can you please let me know how I can return the BrickPi for a check-up?

Could you please give me some advice on how to fix this? What am I doing wrong?


#2

Nocturnaldeep,

I’m sorry to hear about the troubles. Thanks for writing this in-depth post about what you’ve tried. A few quick questions before we arrange a return / replacement.

First, how are you powering the BrickPi?

Second, have you tried any of the sensors, like the touch sensor example in Python?

Third, are you seeing any errors on the command line when you run the motor test? Is it printing “forward” and “backward” over and over again? Or is an error being thrown in the python program?

John


#3

Thanks for replying, I have just a small addition to make that I have recently tried the latest version of Wheezy (2015.x.x) this sadly made no difference to the Brickpi

In answer to your questions

  1. I am powering the BrickPi with both DC in via mains for the Raspberry Pi and a 9V Battery on the BrickPi

2)I unfortunately dont own a sensor for the BrickPi, but have tried the motors in all the sockets when running the LEGO-Motor_Test.Py

3)When I activated the Debug mode in BrickPi. Py I got RXerror :-2 , when I looked into this I saw that this means that the Motors have not received any command from the BrickPi and are effectively ‘Timing out’

I could go one step further and get an Ohms meter and make Doubly sure that the Motors are not broken (Which I think they are not) I could also buy a bigger battery pack, but I would rather not spend so much money on the Brick Pi until I am sure that it is not the BrickPi itself that is at fault

Many thanks and look forward to hearing from you soon


#4

No problem.

It sounds like there’s an issue with communications, which might be the BrickPi not getting enough power. We could send you a BrickPi Power Pack for use with the 8XAA’s to test if you don’t have one. SInce you’re using a 9V battery, that could be an issue. Are you able to power the Pi itself off the BrickPi without the mains hookup? Or are you only able to get the Pi to start with the microUSB and mains plugged in?

The -2 return is indicating we’re not getting a response from the BrickPi; it’s not responding.

Can we try with a stronger power source; either contact us and we’ll try to get you a BrickPi Power Pack; if you have an 8XAA battery pack or even a 6XAA battery pack with fresh AA’s, you should be able to power the Pi off it.

If you can power the Pi off it and still get the -2 response, we probably have a dead BrickPi. If we have a dead BrickPi, we’ll arrange a replacement asap.

Sorry for the troubles! John


#5

Hi John, thanks for your update I’ll try and get a more powerful power pack and try this, I have been running the BrickPi from a 9V battery pack without mains intervention but I gathered that it would be a good idea to use both available power supplies :slight_smile:

Many thanks


#6

Hi,
I have tried the 12V power supply (8XAA Battery pack) and have had a slight improvement but not much, the error message RX =-2 has now gone, and even though I am still in debug mode I am not getting any error messages from the BrickPi, however the motors are still not responding, I have checked, double checked and Triple checked that Debug = 1 is enabled in BrickPi.py and seem to be getting nothing back. by now I am really eager to get on with a project I have been working on, so would it be possible at all to make arrangements to send my BrickPi back for a replacement as soon as possible?

Many thanks


#7

Sure. Can you please contact us here:
dexterindustries.com/contact.html
And include your order information?

Thanks, and again, sorry