Brick Pi Motors


#1

Hi,
I have a similar problem. I run BrickPi out-of-the box, except all SW have been updated. I use RaspPI micro USB power supplly and DI battery box (10.9 V).
LED.py runs as expected, while LEGO-Motor_Test.py returns -2 with motors no working.
Does all this mean that I have a dead board?
Regards
Jerry T


#2

So you had a Raspbian for Robots SD Card you bought from us. Did you run the software update on the desktop? You allude to is. Was it succesful? Did you update the OS from the software update?

You ran the python examples. These did not produce results. Is that right?


#3

Hi and thanks for your first answer.
Yes, I have a Rasbian for Robots SD Card from DI. The OS and Dexter SW has been updated, yes. LED.py produces results (blinking blue diods on the BrickPi board).
LEGO-Motor_Test.py returns error -2. Just as I stated in my first mail. So why do you ask "These did not produce results. Is that right?"
Jerry T


#4

Have you tried this:

http://www.dexterindustries.com/howto/enable-or-disable-brickpi-communications/

If you have the update, you might need to disable the IR Receiver to get the BrickPi to work. Does this help?

John


#5

Hi,
yes, it helps. Thanks a lot. The motors rotate both forward and backward.
But (there is always a “but”, right?)
LEGO-Motor_Test.py outputs:

Running Forward
BrickPiRx Error : -2
BrickPiRx Error : -5
Running Backward
BrickPiRx Error : -2
BrickPiRx Error : -5

and so on. So I wonder: WHY is that?
Jerry