Brick Pi Web Video Streaming


#1

Can we use the GoPiGo Python project “Browser Streaming Robot” to run streaming web video on a BrickPi? The steps for the project seem to work until we get to this command:

sudo ./robot_web_server.py

When I run type this in the Remote Terminal, I get this error:

https://drive.google.com/file/d/0B8fVS1Jyk9puTG5TZV9zQ1hYOXM/view?usp=sharing


#2

Hi @chrisbbates,

The code that you are using works well, only with GoPiGo. We have a separate example for browser streaming robot for BrickPi here. Please run sudo bash browser_stream_setup.sh to setup the packages first. Then follow the ReadME given here to run the browser streaming example.

Please let us know if this helps,
-Shoban


#3

Hi Shoban, thanks for the valuable assistance. We successfully ran sudo bash browser_stream_setup.sh.
Motors and camera are connected.
Make brickpi_web_server.pi executable failed.

I am running the chmod +x brickpi_web_server.py from a remote terminal after I change to the correct directory. What is this new guy doing wrong?
-Chris


#4

Hi @chrisbbates,

You will have to run the chmod +x brickpi_web_server.py as a super user to have it working. So use the command sudo chmod +x brickpi_web_server.py and let us know if this works for you.

-Shoban


#5

Hi Shoban,
We ran the sudo chmod +x brickpi_web_server.py successfully and this is the error we received.

Do i still have some help calls left…:slight_smile: ?

Thanks
Chris


#6

Hi @chrisbbates,

Yeah it looks like your BrickPi_Python files, need an update, we have updated our brickpi_web_server.py and we have resolved this issue in the update. To update your BrickPi_Python folder, run the following commands:
cd /home/pi/Desktop/BrickPi_Python
sudo git pull

If the above commands throw an error, then you can update your software by a DI_update following the guide here. This method will erase any specific codes written by you into the BrickPi_Python folder and you will have to save it in a different folder before trying the update.

After updating, run the brickpi_web_server.py.

Please let us know if this works,
-Shoban


#7

Hello Shoban,

We got an error when we ran the sudo git pull

So we ran the DI_update and that worked fine. We were able to get the web streaming server to run. Here are the issues we found. First, dex.local:98 only worked on a PC, not an Android phone or tablet. Next, Port D didn’t work. We switched connections to verify the motor was good by putting it in Port B and it worked. We also checked the ports using Scratch and Ports A and B worked, but D didn’t.

Do you think we have a bad BrickPi board? How difficult will it be to modify the browswerStreamingRobot.py to use Port B and A instead of B and D?

Thanks,
Chris


#8

Hi @chrisbbates,

Dex.local doesn’t work on android phones. You can refer to this post to have it working on android mobiles.

To change the ports you will have to change the the lines 35,77 and 84 of this library. Change PORT_D to PORT_A in the before mentioned lines.

Please let us know if this works,
-Shoban


#9

Hey Chris, have you tried port D using a cable you know is good? In my experience, although rare, cables will sometimes stop working. Can you also test port C with a cable you know is good?

Matt