BrickPi 3 not working wyliodrin studio


#1

Hi,

I have a BrickPi 3 with a Raspberry Pi 3 model B+ - I’m trying to get it running with wyliodrin studio.

No matter what I do I get the below error. Please help.

Br Torben


#2

It looks like you’re trying to use BrickPi+ drivers with the BrickPi3.


#3

Thak you for your reply, Matt.

Yes it sounds like something like that. But I followed the link from the wyliodrin studio and downloaded the image: “wyliodrinStudioRPi3b+20Nov2018.img”

After that I followed the guide her:
https://projects.wyliodrin.com/wiki/boards_setup/raspberrypi

Do you know what I’m doing wrong? Is the image not the right one?

Br Torben


#4

We don’t support wyliodrin studio. How did you install the BrickPi? On Raspbian you can install the BrickPi3 drivers using the command curl -kL dexterindustries.com/update_brickpi3 | bash


#5

I haven’t installed anything besides the image I referred to in my previous reply.

I’m getting an error when I try to install the drivers :frowning:Capture


#6

You are using the -l option instead of -L - notice the capital letter. It should have been -kL and not -kl.

Thank you!


#7

Ohh my bad :frowning:
I tried again and I managed to install the drivers, but still getting the same error.

I give up.

Thanx for your help.

Br Torben


#8

Hi @torben,

Well, we don’t know what Wyliodrin studio implements in their OS, so can you give this a try on a pure Raspbian or Raspbian For Robots?

Thank you!


#9

Hi @RobertLucian and thank you for your reply.

I will try that at a later point. But I contacted Wyliodrin and they wrote this:
"Hello, on the Raspberry Pi 3 B+ the standard serial port is dev/ttys0 instead of dev/ttyAMA0. Please ask Dexter Industries on advice for this. "

Generally the documentation (Wyliodrin) around this is very poor

Does that make sense to you guys?

Br
Torben


#10

If you’re still getting the same error, you’re still trying to use BrickPi+ drivers with the BrickPi3. Serial port dev/ttys0 vs. dev/ttyAMA0 is irrelevant, since the BrickPi3 doesn’t use a UART serial port.


#11

Thanx Matt,

I give up due to lack of support from Wyliodrin.

Once again thak you for your time.

Br
Torben