BrickPi+ boots, wait, and shuts down


#1

I recently was trying out other os images like Raspbian, but decided to get the Dexter Industries Image again. I downloaded the Dexter Industries BrickPi+ Image for my Raspberry Pi to have a ‘clean palette’ and unzipped it using Ubuntu’s extract function and used Etcher to burn the .img file to my 16GB SD card. However, upon boot the Raspberry Pi will go through a normal boot process (sidenote: I have the same odd boot process as here, but it has previously worked after booting weird) but after fully booting up, will take a few seconds to about a minute on just a blank gray screen before going through the shutdown process. It happens quite reliably, but once I got to the Desktop by pressing as many buttons as I could think of, like [ctrl]…c,x,s,q, and space bar, but that only happened once. When it did properly boot, there was nothing noticeably wrong in any files. I’ve tried two different downloads of the zip files, but I haven’t gotten anywhere.

Is there a checksum for the os image zip file, or a reason it could boot up and then off with the image straight from Dexter Industries?


#2

@Wookieintheyard , wanted to make sure we’re doing a few things first:

  1. Are you using these directions to download and install the image? Just want to make sure you’re using the very latest image, Raspbian for Robots, maybe from sourceforge (this comes with an MD5 checksum packaged in the zip.

  2. Are you powering with a USB power source? Is it a certified 2A power source? What you’re describing sounds like the power is dipping too low at some point and causing a reset or causing the Pi to go into a power zone. I would try to power everything with a very reliable 2A USB power source when you boot, and if that solves the issue, find some new batteries.

Thanks!


#3

Check if the GPIO pins are not covered.


#4

I checked the md5 sums of my downloads and they do not match with the md5 provided. I tried flashing the SD card form another computer but it still had the same problem. I think my issue is with the power source. I normally use a 5V and 2.5A cord. I tried USB cables from my computer and also tried using the 12V battery pack with new batteries. I also tried plugging in to the micro USB and the brickpi port at the same time. Nothing has worked, and I noticed that the rainbow screen flashes momentarily every time I boot up. Should I get a new power source, or does it seem like my pi is messed up?


#5

Try the google drive image. The link should be on the instructions page here;
https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/


#6

Does normal Raspbian work? Because it sounds like it’s just Raspbian for Robots. Especially because the md5 hash is different.


#7

I’ve tried sourceforge and google drive and I had tried Raspbian, but I had trouble with adapting it for BrickPi. I might give Raspbian another try, though.


#8

After you run the install.sh script in the Install/ folder if it doesn’t work try running the setup.py script under BrickPi3/Software/Python/

To use it I believe it is python3 setup.py --install To use it for python 2.7 you’ll have to use pyhon to install rather than python3 That should work. Currently I’m using Raspbian Jessie lite with my BrickPi3.


#9

Raspbian Jessie Lite works and runs fine, but I’ve done all the steps to modify the os and I got the error ImportError: No module named BrickPi with my own program (is this cause my file isn’t within the BrickPi files? the example programs don’t have this error) and ImportError: No module named builtins (because BrickPi.py starts with from builtins import input) with and example program, so did as you said and went to the directory with setup.py and tried python setup.py and python setup.py --install and got ImportError: No module named setuptools both times. Should i just try and use apt-get or pip to install each module or is there a better workaround?


#10

Sorry. I forgot to say that I also had to install a zillion things to not only import the library but also use it. The reason is that Raspbian lite is a bear minimal install or close to that. This means your lucky if Python came with it! So you’ll have to install setup tools probably with sudo -H pip3 install setuptools` or something like that. Not to mention the RPi GPIO library will have to be installed among​ other things. However if you use just normal Raspbian it should work.

If your wondering why I use Raspbian lite, it is because I simply didn’t want stuff like a X server, Minecraft, and a bunch of stuff I don’t need just to run my robot.


#11

Hey @Wookieintheyard. Just to hop in here, it sounds like you have most of what you need. The module builtins can be installed using

sudo pip install future

I’m not sure why you’re getting no module named BrickPi but, to solve in the short term, you can drag the BrickPi.py driver into the same directory as your example program.

Does this help?


#12

I downloaded Raspian Jessie with Desktop and it has all the modules pre-installed. It works nicely and solved the problem, but it could be an issue with a small SD card.


#13

Yes it would help to install future. But there are many, many modules needed. Just because the BrickPi3 module even I stalled doesn’t mean it works yet. I still had to I stall stuff like hardware modules and lots of stuff to make a motor move.


#14

What could be an issue?


#15