BrickPi+ drivers


#1

I have a BrickPi+ that is not responding and is showing no signs of life. I have looked through many threads to try and solve the problem and seem to have come to the conclusion that the drivers on the RaspberryPi are for BrickPi3. Throughout my troubleshooting I get errors that BrickPi3 is not connected. The test and Troubleshooting program in Raspbien is only for BrickPi3.

where can I find the drivers and how I get them in order to get my brick pi working.


#2

Exactly, the drivers are for the BrickPi3. Have you tried following the tutorial for the BrickPi?
https://www.dexterindustries.com/BrickPi/brickpi-tutorials-documentation/getting-started/


#3

I had tried those, I have been able to get the motor test examples in Scratch working, when I try some tutorials that do not use the keyboard to initiate they do not work. When it comes to the sensor examples those run event without it being prompted. For example the Touch one will tell me the sensor has been pressed when I have not done anything and will loop consistently like this. As for the motors when I try to create a new program they do nothing. When I click start programming in Scratch I get the following comments in the terminal:

BrickPi Scratch: Scratch is either not opened or remote sensor connections aren’t enabled
BrickPi Scratch: Unable to Broadcast
BrickPiScratch: Scratch connection error, Retrying
BrickPi Scratch: Connetion to Scratch successful

Here is what I have tried in as new program to get motors running
Broadcast MA30
Broadcast MD30
wait 1 sec
Broadcast MA0
Broadcast MD0

nothing happens when I run this. it is exactly the same as a tutorial I found and theirs runs the motors for 1 second.

On another note, when I go to use the sensor value command, I can not change the slider option to one of my sensors.

Sorry for being so long winded but I want to give as many details as possible. I’m sure it is something simple that I am missing but I just don’t see it.


#4

Hello,
may I ask whether you’re running Raspbian for Robots or your own Raspbian from Noobs/Raspberry Pi Foundation?

The drivers for the BrickPi+ will be found in /home/pi/BrickPi+/Software
Those for BrickPi3 are in /home/pi/BrickPi3/Software

Both sets are present on Raspbian for Robots

Cleo


#5

I am running Raspbian for Robots. I have even tried Cinch. I have explored and files within the BrickPi folders without any advancements into making it work.


#6

Are you able to get a screenshot of what you see in VNC?


#7

here are two screenshots. The first one is when I click start programming on Scratch. No changes to this after I have tried to run a program I created.

This second one is when I open and run The Touch Sensor example.


#8

THanks for the screenshots. I would need to see the desktop itself though. It would let me know what robot is being detected and a bunch of other info. Just the desktop the way it shows in VNC, if that’s not too much trouble


#9

Here is the desktop. hope it helps.


#10

Thanks!
So your BrickPi+ is still a good BrickPi+, I can confirm that.
It does seem however that we have a potential issue with Scratch and the BrickPi+ I’m currently investigating.

I’ll report as soon as I find something


#11

Oh et bonjour! Je viens de remarquer la boîte de courriel en français :slight_smile:


#12

Parfait, merci beaucoup. Ma boîte de courriel est en français mais je suis complètement bilingue - il ne fait pas de différence la langue utiliser.


#13

Same here. We’ll keep English so others can follow :slight_smile:
Ok, turns out there isn’t an issue with Scratch. I was just shooting myself in the foot, trying to use an EV3 touch sensor with NXT touch code.
#notmyday

For motors and the BrickPi+, you have to first enable the motors. This script is supposed to work


#14

Still not working, I’m getting nothing. I even tried putting the motor in all ports just in case I had it in the wrong on. Is this NXT or Ev3 code? I am using ev3.


#15

Sorry, I couldn’t find this thread again… Weird. Now it shows up.

The code I sent you works for both EV3 and NXT motors. Is there anything in the terminal window that’s hiding behind Scratch?


#16

I don’t believe there is anything other than what’s in the first screenshot of the terminal that I posted earlier in the feed. I will have to double check when I get back to school. I am away tomorrow so I will check first thing Wednesday.


#17

Nothing else in the terminal except for when I open it and click on Start programming. Here is the screen shot.

I must be missing something simple. Is there anything in particular I have to do in scratch before starting to program?


#18

You’re not missing any step that I can think of. How do you start the program within Scratch? Also have you tested the BrickPi+ with Python?
There’s a hardware test at either
/home/pi/Dexter/BrickPi+/Software/BrickPi_Python/Sensor_Examples/BrickPi_Hardware_Test.py
(this path will only work if you have updated your Raspbian for Robots since January.)

In case you are not familiar with Python
cd /home/pi/Dexter/BrickPi+/Software/BrickPi_Python/Sensor_Examples python BrickPi_Hardware_Test.py

do let me know what this program says.

Cleo


#19

I start Scratch directly from the shortcut on the desktop.

I was testing in Python and there were a few programs giving me errors so could not run them as I tells me I do not have the rights to make modifications (the hardware test being one of them). The ones I could get working work, But still nothing in Scratch.


#20

Where can I find programming tutorial for Python? I have been searching online and only finding examples that do not use the BrickPi. I guess I am mainly looking for the functions and codes that are used