BrickPi image and sensor issues


#1

We have been testing the BrickPi for a week and encountered some issues.

1. We downloaded 2 different Raspbian for Robots images => the images did not work on battery power, and on wall power the pi immediately goes
into a kernel panic

We had to use the GoPiGo install scripts to setup the brickpi on our Debian 8.4 Jessie image => The script did not add “init_uart_clock=32000000” to /boot/config.txt, which is a needed entry. So we had to manually add the one line.

2. We downloaded the brickpi python module and examples.
a. The LEGO-* examples work fine
b. When we tried the EV3-* examples the sensor readings are very odd. We have not been able to solve all these issues yet.

  1. The color sensor in mode 2 gave values above 7 half the time
  2. The touch sensor example code sometimes returns pressed even though it is released
  3. The Infrared and Gyro example code often returns 1023 continuously from 1 second to over 5 minutes at a time

Here is a link to our image with our fixes if you are interested:

Please let us know if we are doing something wrong.


#2

Hello
I’m trying to look into the image issue.
If you don’t mind answering the following questions, it would help me a lot.

  1. What are the names of the images that you tried, and which one gave you a kernel panic?
  2. when you mention the GoPiGo install script, I’m assuming you mean the BrickPi one? Which script did you run?

Thank you for your hand in this.

There had been an issue for a short while with the init_uart_clock=32000000 not being set properly, but that was supposed to have been fixed.
Cleo


#3

We decided to start from scratch to see if we were doing something wrong. We got “2016.05.16_Dexter_Industries_jessie.img” version of Raspbian for Robots to work. We still had some major issues.

  1. Using the Gyro sensor and using EV3-Gyro.py program, we get the correct angle output printed often when we are moving the gyro. However, when the gyro is relatively still, we mostly get an output of 1023. This makes using the gyro for turns or moving straight almost impossible, which makes the gyro mostly unusable (even with filtering out the 1023 values).

  2. The EV3 Ultrasonic sensor also outputs 1023 most of the time. It infrequently outputs other values in the range of 40-100. This measurement fluctuates frequently but looks like it might be mm instead of cm. Unfortunately, even if this is a mm measurement, it is also unusable (even with filtering out the 1023 values). We tried a NXT Ultrasonic sensor - that worked fine.

  3. The color sensor also output 1023 values - but the correct readings were frequent and stable enough (in color mode) that the sensor was usable. We have not tested other modes.


#4

We did receive any response to the post from June 11th. Does anyone have any suggestions for our issues with the sensors?


#5

Hi Sheshan brothers, we’re still working on this issue. I’m sorry for the delay. I’m trying to recreate the issue on my end.