BrickPi Image Update 2014.01


#1

Folks,
We’ve updated the image for the BrickPi. Based on a lot of the issues we’ve seen here, we’ve tried to add some improvements.

Here’s the sourceforge Download: http://sourceforge.net/projects/dexterindustriesraspbianflavor/

If the BrickPi image from 2013 still works for you, not a problem. This image is built off the latest version of Raspbian and should solve some of the wifi problems and login problems folks have brought up. Some notable changes:

    Bonjour is installed. If you have Bonjour on your PC, you should be able to plug the Raspberry Pi into the wifi network your PC is connected to with an ethernet cable, and login on on the IP address "raspberrypi.local"
    The Wifi GUI should be working now.
    Python is installed and setup.
    The latest Github repositories are installed.
We would love your feedback if anyone gives this a shot!

#2

Runs a treat. Everything works so far. I’ve been using Scratch, but I think I need to get going on Python to get the most out of it. Our next Coder Dojo session will be building the WiFi Car. I’ll post some images etc.


#3

Hi -

I’m having issues with the 2014.01.20_Dexter_Industries_wheezy.img.zip file.

I’ve downloaded from both Dexter and Goolge and unzip either gives a checksum error.

I can burn it to an SD card and is starts to boot, but then blows up a lot of file system errors. I’ve tried this on a couple of cards - so am pretty sure it’s all a bad image file.

Would you be able to check the file and replace if you find it bad?

thanks
gtbrick


#4

gtbrick, sorry to hear about the challenges.

I think the most reliable way to get the BrickPi image is to download the RAR file from this link on sourceforge:

Can you give it a shot?


#5

Also, is there any reason you’re using the January edition? We have one released in March that has a lot of improvements. . . the latest one on Sourceforge.


#6

Hmmm - the title on the link is 2014-3-13 but the name of the image that gets downloaded is 2014-1-20

Is the link pointing to the right image?

thanks for checking


#7

I think I see the problem. Were you downloading from the Google Drive links? I’m reposting those, they were never updated when we released the latest March edition. Done in a minute, I’ll update the links once we have the latest uploaded to Drive! Very sorry for the confusion and the long wait.


#8

Hi I have just downloaded the 3rd March image and it seems to work ok but the MD5 Hash is coming up as d64488a32aa2bd088c504ff863d3e87e - not what is shown on ‘pi-prep’ page - can you confirm if this is ok - ie do you need to update the web page ?

Thanks


#9

I am not able to use link the Wireless Adapter (came with kit - just 2-3 weeks ago) to my router. I have download and imaged the March image. I have tried making the changes to interfaces (per instructions), using static and dhcp regular and all I get is a blinking red indicator.
I do not use WPA/WEP but only MAC address as security. I added the MAC address to my router. I have used the WiFi utility to ADD my wireless SSID. I must be doing something wrong. Still no luck.
sudo ifconfig is not seeing my IP Address but the APIPA address - somehow not linking!


#10

Hey DavidMS, you’re right! We’ll change that immediately. The correct hash for 2014.03.03_Dexter_Industries_wheezy.img is

d64488a32aa2bd088c504ff863d3e87e


#11

Hey gtbrick, have you tried our sourceforge download? It seems there are problems for some people downloading from different sources.

http://sourceforge.net/projects/dexterindustriesraspbianflavor/files/?source=navbar

You can download the rar or zip file from that link. I would recommend the rar file if possible.


#12

This image has been updated as of June 5, 2014. Thanks!