BrickPi Import Error!


#1

Hi, this is my first post, and I may be noobish at BrickPi, so please bear with me.

So I am entering into a competition called the ESC (european student convention) and I had the idea of for my science engineering project, making goal-line technology using BrickPi. I eventually downloaded BrickPi, and I thought I got it on my Raspberry Pi ok. But, however, now as I am trying to make my own code via Python, I am incountering a problem. During the code, it tells me that the command ‘Import’ is not valid. I wondered whether I had not done the setup of BrickPi right, and i looked around on the program it page of the main forum to see if i hadnt done a step. As it happened, i hadnt typed out Importy BrickPi in the LXTerminal. So, I typed in the LXTerminal, import BrickPi. and it tells me bash: import: command not found. if anyone can tell me how to get this command to register I would highly appreciate it. Thank you

Sam


#2

Hi Sam,
For development in Python, you’ll need to download the BrickPi_Python pachage. Here’s the link to the package (https://github.com/DexterInd/BrickPi_Python).

Once you have downloaded the Package, run the setup.py to configure python using the following: python setup.py install.

If you are not using the DexterIndustries flavour of Raspbian, I’ll suggest you to run the setup script to install all the software’s and other settings required by BrickPi. The install script is available in the “Setup Files” folder in the BrickPi repositiory. Here’s the link (https://github.com/DexterInd/BrickPi). After downloading the repository just go to the “Setup Files” folder, make the “install.sh” executable by chmod +x install.sh and run it ./install.sh.

Hope that this helps. Please let us know if you still face any problems.

Thanks,
Karan


#3

Hi-

I think is related enough to attach it here. I’ve been having problems trying to change into the “Setup Files” directory. I cloned “(https://github.com/DexterInd/BrickPi)” and then changed into the BrickPi directory. A ls shows various directories including “Setup Files” but when I try to "cd Setup Files"
i get “bash: cd: Setup: No such file or directory”

when i cd into other directories i.e. “Image” there’s no problem. when i cd into “Firmware_BrickPi”, again no problem. but any directory with a space returns the error message.

I’ve tried to include an underscore “Setup_Files” and even this “Setup%20Files”, same message.

pretty new to Linux, but i’m stumped.

thanks for any help
Hoggindapotti


#4

Hi Hoggindapotti,
This should help “cd Setup Files”.

A simple way to select folders is to just type the first few letters and press TAB, like cd Set (Press TAB). This helps a lot when you are entering the path to a file or folder.

Sorry for the confusion.

Karan


#5

worked like a charm! thanks very much for the prompt response.

-best
Hogginda